Ask Your Question
0

build of gazebo package not working

asked 2011-11-14 00:21:47 -0500

oro gravatar image

Hello, I am running the latest Ros electric with Ubuntu 11.10. I am encountering some problems when trying to build gazebo and could really use some help.

The first problem when trying to build gazebo is:

/home/oro/ros/stacks/simulator_gazebo/gazebo/build/gazebo/server/audio_video/AudioDecoder.cc: In member function ‘int AudioDecoder::Decode(uint8_t**, unsigned int*)’:
/home/oro/ros/stacks/simulator_gazebo/gazebo/build/gazebo/server/audio_video/AudioDecoder.cc:105:49: error: ‘avcodec_decode_audio2’ was not declared in this scope
/home/oro/ros/stacks/simulator_gazebo/gazebo/build/gazebo/server/audio_video/AudioDecoder.cc: In member function ‘int AudioDecoder::SetFile(const string&)’:
/home/oro/ros/stacks/simulator_gazebo/gazebo/build/gazebo/server/audio_video/AudioDecoder.cc:152:7: warning: ‘int av_open_input_file(AVFormatContext**, const char*, AVInputFormat*, int, AVFormatParameters*)’ is deprecated (declared at /usr/include/libavformat/avformat.h:1050) [-Wdeprecated-declarations]
/home/oro/ros/stacks/simulator_gazebo/gazebo/build/gazebo/server/audio_video/AudioDecoder.cc:152:75: warning: ‘int av_open_input_file(AVFormatContext**, const char*, AVInputFormat*, int, AVFormatParameters*)’ is deprecated (declared at /usr/include/libavformat/avformat.h:1050) [-Wdeprecated-declarations]
/home/oro/ros/stacks/simulator_gazebo/gazebo/build/gazebo/server/audio_video/AudioDecoder.cc:172:59: error: ‘CODEC_TYPE_AUDIO’ was not declared in this scope

I tried just commenting those parts out, which seems to work so far.

The next problem are a lot of undefined references like the following ones:

rendering/libgazebo_rendering.so: undefined reference to `Ogre::Camera::getCameraToViewportRay(float, float) const'
libgazebo_server.so.0.10.0: undefined reference to `Ogre::AutoParamDataSource::AutoParamDataSource()'
rendering/libgazebo_rendering.so: undefined reference to `Ogre::MovableObject::~MovableObject()'
rendering/libgazebo_rendering.so: undefined reference to `Ogre::Pass::setDiffuse(float, float, float, float)'

The whole list would be too long to post here (if needed I can add it), but they are all undefined references to Ogre methods.

Is this a problem with my ogre installation or can someone tell me where my problem really is?

Thanks in Advance!

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2011-11-14 02:57:41 -0500

As your using Ubuntu, I'd suggest you use the prebuild Debian packages to install gazebo:

sudo apt-get install ros-electric-simulator-gazebo

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-14 00:21:47 -0500

Seen: 442 times

Last updated: Nov 14 '11