Ask Your Question
0

Trouble with tutorial

asked 2011-11-01 15:33:19 -0600

ww3ace gravatar image

I am new to linux, but I'm trying my best to deal with the terminal command line. I've finally got the right version of linux and ros diamondback installed in a virtual machine and I'm trying to work my way through the tutorials so I can eventually be able to port a control system onto a quadrotor. I've gotten to the "Create a Package" tutorial and I can't get roscd working. It returns "roscd: command not found". I did some digging and apparently the installations have changed some policy having to do with the difference between setup.sh and setup.bash:

As of rosinstall version 0.5.12 it will no longer use bashisms in the setup.sh file. They have been moved to setup.bash. And for zsh users there is also a setup.zsh generated.

For existing bash users this will mean that until you switch to use setup.bash instead of setup.sh you will not have the command line tools you are used to such as rosrun roscd and tab completion.

The tutorial only instructs me on how to create a setup.sh file. There is no setup.bash file in my tutorial directory so I can't just write setup.bash vs setup.sh in my bashrc file. Can anybody help me?

edit retag flag offensive close merge delete

Comments

Is there a specific reason why you're using diamondback instead of the latest version (electric)?
Daniel Canelhas gravatar imageDaniel Canelhas ( 2011-11-02 01:16:17 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2011-11-01 22:47:02 -0600

CaptainTrunky gravatar image

Hello! Strange, but I have setup.bash (ubuntu 11.04, Electric).

But I can say, that you don't really need in roscd/rosls etc. You can use standard linux commands, like cd or ls, with the same result (you only should to use full path to directory, e.g. 'roscd yourProject' vs 'cd ~/ros/yourProject'). It's not so comfortable, but it works!

If you really need in setup.bash - here it is.

edit flag offensive delete link more
1

answered 2011-11-01 23:22:05 -0600

noonv gravatar image

go to /opt/ros/electric/ and look for setup.sh try to

sudo chmod +x /opt/ros/electric/setup.*

after that check - have you

/opt/ros/electric/setup.bash

in your ~/.bashrc

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-01 15:33:19 -0600

Seen: 1,187 times

Last updated: Nov 01 '11