ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

The error is in tutorial # 14 (writing a simple service and client) Beginner Level. CMake Error!

asked 2014-01-11 20:48:06 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

In tutorial 14, when I run catkin_make at the end of the tutorial, I get error saying: CMake Error at beginner_tutorials/CMakeLists.txt:33 (add_executable):Cannot find source file: src/add_two_ints_client.cpp Tried extensions ... (HERE DIFFERENT EXTENSIONS ARE WRITTEN) --Build files ... (HERE Some files are written) Invoking "make cmake_check_build_system" failed

While trying to remove this error, I tried many times. I even tried after deleting all previous beginner tutorials files from my catkin workspace and performed tutorials 1,3,4,10,14 again (many times), But still no solution!

I checked in my scr folder, the file add_two_ints_client.cpp is actually present there!! My ROS version is hydro. My OS is Ubuntu 12.04 LTS.

Please help resolve issue. I have a snapshot of error but ROS Answers says I have to have karma points>20 to upload that. So, I cannot upload that! Moreover, I am very new to ROS and Ubuntu!


edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2014-07-31 04:38:40 -0600

your file name must be "add_two_ints_client.cpp(space)"

i have the same problem just like you

delete the "(space)" and then your command can work

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2014-01-11 20:48:06 -0600

Seen: 522 times

Last updated: Jan 12 '14