Fatal - pan_tilt_port: No motors found

asked 2014-01-10 20:01:50 -0500

lfelipesv gravatar image

updated 2014-01-11 03:50:08 -0500

gvdhoorn gravatar image

Hello Everyone, I'm following the tutorial dynamixel_controllers/Tutorials/ConnectingToDynamixelBus and I cannot found my motor AX12+. I'm testing just one AX12+ on Linux 12.04 and 13.04 and both do not work.

My ls -la /dev/ttyUSB output is:

crw-rw-rw- 1 root dialout 188, 0  1월 11 16:52 /dev/ttyUSB0

When I ran the roslaunch command my last lines before the error are:

setting /run_id to 4e5d5690-7a95-11e3-bc0f-e0cb4e79fce2
process[rosout-1]: started with pid [28760]
started core service [/rosout]
process[dynamixel_manager-2]: started with pid [28772]
[INFO] [WallTime: 1389426744.355062] pan_tilt_port: Pinging motor IDs 1 through 25...
[FATAL] [WallTime: 1389426746.482201] pan_tilt_port: No motors found.

I already tried with 3 different AX12+ motors and always the same error. I'm using a 9V power supply and seems perfectly working, the motor blink once when the power source is connected.

Thank you very much for the attention.

edit retag flag offensive close merge delete

Comments

You should post your launch and parameter files.

arebgun gravatar imagearebgun ( 2014-02-27 08:56:00 -0500 )edit