Ask Your Question
0

Problem with teleop_base stage tutorial, how to install 'joy' package?

asked 2011-10-24 22:12:34 -0500

marcobecerrap gravatar image

updated 2011-10-24 23:05:11 -0500

Hi, I'm trying to make the teleop_base tutorial, the first one for the stage simulator. At the moment of compile it requires me to install the joy package. I've found it available here but I don't know how to install it. Could someone please give me a help telling me the best/easiest way to do this?

I'm using Ubuntu 11.10 Oneiric Ocelot and ROS-Electric.

Thanks!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
4

answered 2011-10-24 22:48:25 -0500

dornhege gravatar image

updated 2011-10-25 00:11:39 -0500

For electic and ubuntu install:

sudo apt-get install ros-electric-joystick-drivers

edit flag offensive delete link more

Comments

Hi, I believe there is a little mistake "electric", but when I run the command "sudo apt-get install ros-electric-joystick-drivers" my PC just can't find it in the repositories... I don't know if this stack it's still suported in ROS-electric. Thnx for your help dornhege.
marcobecerrap gravatar imagemarcobecerrap ( 2011-10-24 22:58:33 -0500 )edit
Yes, I fixed the typo. I'm not sure, if there is oneiric support yet. It should work from lucid to natty.
dornhege gravatar imagedornhege ( 2011-10-25 00:14:44 -0500 )edit
0

answered 2014-04-29 13:12:25 -0500

ros-electric-* is not in the apt-get stack anymore. just replace ros-electric-* with ros-fuerte-* and you are good to go.

in you case use sudo apt-get install ros-fuerte-joystick-drivers

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-10-24 22:12:34 -0500

Seen: 1,141 times

Last updated: Apr 29 '14