ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

problem with tf No transform from /laser_link to frame /odom

asked 2014-01-09 05:23:19 -0500

bvbdort gravatar image

updated 2014-01-10 03:05:43 -0500


I am new to ros, i am trying to view pointcloud in rviz. But i have problem with tf.

I am publishing /odom -> /base_link using [tf::TransformBroadcaster]

and /base_link -> /laser_link as static transform from launch file.

<node pkg="tf" type="static_transform_publisher" name="laser_link_tfS" args="1 3 2 0 0 0 base_link laser_link  1000" />

But in rviz its showing No transform from [/laser_link] to frame [/odom]

I tried urdf file but i didnt solve the problem.

thanks in advance.


rosrun tf view_frames

output pdf is here http:// www. (remove spaces)

edit retag flag offensive close merge delete



could you show frames graph ? you can generate pdf file of it with `rosrun tf view_frames`. Also you could try increasing publishing rate from 1000 to 100

rock-ass gravatar image rock-ass  ( 2014-01-10 02:15:12 -0500 )edit

@rock-ass frames pdf added.

bvbdort gravatar image bvbdort  ( 2014-01-10 03:09:40 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2014-01-10 02:53:49 -0500

updated 2014-01-10 03:21:15 -0500

The most likely cause I can see from your description of the problem is that the timestamp of the tf transform you´re broadcasting is not correct. As requested also in a comment, you should edit your post with further info. You can also try both of these commands:

rosrun tf tf_echo base_link laser_link 
rosrun tf tf_echo odom base_link

If the first one fails to show a transfom, your static publisher does not work. if the second one fails, your TransformBroadcaster is the culprit.

/edit: As you can see from the posted frames.pdf, the transform between odom and base_link published to tf is 44 years old, while the transform published to by the static publishers is timestamped ~0.5 seconds into the future (as it should be). This suggests you don´t timestamp the data when publishing via the TransformBroadcaster correctly.

edit flag offensive delete link more


for both commands its showing warning TF_OLD_DATA ignoring data from the past for frame /imu_link at time 0 according to authority /odom_publisher_node

bvbdort gravatar image bvbdort  ( 2014-01-10 03:08:51 -0500 )edit

See edit above. Fix the timestamp and try if it works then.

Stefan Kohlbrecher gravatar image Stefan Kohlbrecher  ( 2014-01-10 03:22:03 -0500 )edit

It worked after adding ros::Time::now(); thanks

bvbdort gravatar image bvbdort  ( 2014-01-10 03:36:31 -0500 )edit

Insightful answer, didn't thought of timestamps in first place

rock-ass gravatar image rock-ass  ( 2014-01-10 11:39:51 -0500 )edit

Question Tools

1 follower


Asked: 2014-01-09 05:23:19 -0500

Seen: 4,951 times

Last updated: Jan 10 '14