Ask Your Question
0

error while loading shared libraries: libtinyxml.so.2.6.2: cannot

asked 2011-10-21 08:15:29 -0500

marin gravatar image

updated 2011-10-21 08:16:06 -0500

Hi everyone, since the past several days I have been having issues with libtinyxml I guess. This is what happens:

iitrobotics@iitrobotics-Satellite-T135:~$ rosrun rviz rviz
/opt/ros/electric/stacks/visualization/rviz/bin/rviz: error while loading shared libraries: libtinyxml.so.2.6.2: cannot open shared object file: No such file or directory

I'm not sure how to correct this. Thanks for any help

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2011-10-22 03:41:06 -0500

The ROS repository used to contain a backported libtinyxml2.6.2 for Natty, but it has been removed for some reason, although the built packages still need it. You can download it from http://archive.ubuntu.com/ubuntu/pool/universe/t/tinyxml/. You need the libtinyxml2.6.2_2.6.2-1_*.deb file for your architecture (i386 or amd64).

I assumed this was a temporary problem. Is there going to be an official fix, or should I open a ticket?

edit flag offensive delete link more

Comments

We realized we had the backport accidentally in our repo and removed it. The latest debs in the repo should have been rebuilt to use the native tinyxml version, if that's not true please do ticket it.
tfoote gravatar image tfoote  ( 2011-10-22 06:33:13 -0500 )edit
thanks for the reply i will try what you suggested in the morning. Thanks!
marin gravatar image marin  ( 2011-10-22 12:08:54 -0500 )edit
1
Worked great. Thanks for submitting the ticket
marin gravatar image marin  ( 2011-10-24 17:12:20 -0500 )edit
The debs have been fixed on Maverick and Natty to use the built in version. An update and upgrade should fix it.
tfoote gravatar image tfoote  ( 2011-10-25 08:46:56 -0500 )edit
It's fixed now. Thanks for the swift update!
roehling gravatar image roehling  ( 2011-10-25 18:46:53 -0500 )edit
0

answered 2011-10-27 01:18:24 -0500

asrinivasan31 gravatar image

updated 2011-10-27 02:13:16 -0500

I have tinyxml showing that it has been installed in ubuntu software center, yet I still get the above error. Any ideas why? This happened after I updated ROS-electric 10 min ago. The above comments imply that this should have already been fixed by now... Note: I tried to doing the sudo apt-get upgrade as well after the update and still nothing.

edit flag offensive delete link more

Comments

Try the following command to see if your ROS is linked against version 2.5.3: ldd $(rospack find rviz)/bin/rviz | grep tinyxml
roehling gravatar image roehling  ( 2011-10-27 02:18:45 -0500 )edit
Yep, did the command and its linked to 2.5.3. I am new to linux as well so how do I go about changing the link?
asrinivasan31 gravatar image asrinivasan31  ( 2011-10-27 02:42:24 -0500 )edit
The link is perfectly fine, unless you have Ubuntu 11.10. Try: sudo apt-get install libtinyxml2.5.3
roehling gravatar image roehling  ( 2011-10-27 03:05:20 -0500 )edit
Thank you! It seems I already had the libtinyxml2.5.3 in the rospack directory under /tools but somehow didn't get installed? Anyway, doing it your way works.
asrinivasan31 gravatar image asrinivasan31  ( 2011-10-27 03:28:12 -0500 )edit
I just updated ros-electric (Dec 18) on Maverick and had the same problem. Installing the correct libtinyxml manually fixed the problem, but it appears the debs are still broken :(
sedwards gravatar image sedwards  ( 2011-12-18 07:18:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-10-21 08:15:29 -0500

Seen: 3,566 times

Last updated: Oct 27 '11