Ask Your Question
0

Building ROS for intel Galileo fails

asked 2014-01-07 03:49:21 -0500

r2djoe gravatar image

Trying to follow the how to (it says link to it but doesn't let me link because I haven't the karma) leads to the following error log

../i586-poky-linux-libtool --mode=link i586-poky-linux-gcc  -m32 -march=i586 --sysroot=/home/peter/devel_gal/meta-clanton_v0.7.5/yocto_build/tmp/sysroots/clanton -o setfattr -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed  -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed  -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed   setfattr.o   ../libmisc/libmisc.la ../libattr/libattr.la  
attr.o: In function `usage':
/home/peter/devel_gal/meta-clanton_v0.7.5/yocto_build/tmp/work/i586-poky-linux/attr/2.4.46-r4/attr-2.4.46/attr/attr.c:45: undefined reference to `libintl_gettext'
attr.o: In function `main':
/home/peter/devel_gal/meta-clanton_v0.7.5/yocto_build/tmp/work/i586-poky-linux/attr/2.4.46-r4/attr-2.4.46/attr/attr.c:69: undefined reference to `libintl_bindtextdomain'
/home/peter/devel_gal/meta-clanton_v0.7.5/yocto_build/tmp/work/i586-poky-linux/attr/2.4.46-r4/attr-2.4.46/attr/attr.c:70: undefined reference to `libintl_textdomain'
/home/peter/devel_gal/meta-clanton_v0.7.5/yocto_build/tmp/work/i586-poky-linux/attr/2.4.46-r4/attr-2.4.46/attr/attr.c:136: undefined reference to `libintl_gettext'
/home/peter/devel_gal/meta-clanton_v0.7.5/yocto_build/tmp/work/i586-poky-linux/attr/2.4.46-r4/attr-2.4.46/attr/attr.c:176: undefined reference to `libintl_gettext'
/home/peter/devel_gal/meta-clanton_v0.7.5/yocto_build/tmp/work/i586-poky-linux/attr/2.4.46-r4/attr-2.4.46/attr/attr.c:91: undefined reference to `libintl_gettext'
/home/peter/devel_gal/meta-clanton_v0.7.5/yocto_build/tmp/work/i586-poky-linux/attr/2.4.46-r4/attr-2.4.46/attr/attr.c:240: undefined reference to `libintl_gettext'
/home/peter/devel_gal/meta-clanton_v0.7.5/yocto_build/tmp/work/i586-poky-linux/attr/2.4.46-r4/attr-2.4.46/attr/attr.c:199: undefined reference to `libintl_gettext'
attr.o:/home/peter/devel_gal/meta-clanton_v0.7.5/yocto_build/tmp/work/i586-poky-linux/attr/2.4.46-r4/attr-2.4.46/attr/attr.c:230: more undefined references to `libintl_gettext' follow
collect2: error: ld returned 1 exit status
make[2]: *** [attr] Error 1
make[2]: Leaving directory `/home/peter/devel_gal/meta-clanton_v0.7.5/yocto_build/tmp/work/i586-poky-linux/attr/2.4.46-r4/attr-2.4.46/attr'
make[1]: *** [attr] Error 2
make[1]: *** Waiting for unfinished jobs....
i586-poky-linux-libtool: link: i586-poky-linux-gcc -m32 -march=i586 --sysroot=/home/peter/devel_gal/meta-clanton_v0.7.5/yocto_build/tmp/sysroots/clanton -o .libs/getfattr -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed getfattr.o  ../libmisc/.libs/libmisc.a ../libattr/.libs/libattr.so
getfattr.o: In function `print_attribute':
/home/peter/devel_gal/meta-clanton_v0.7.5/yocto_build/tmp/work/i586-poky-linux/attr/2.4.46-r4/attr-2.4.46/getfattr/getfattr.c:258: undefined reference to `libintl_gettext'
getfattr.o: In function `help':
/home/peter/devel_gal/meta-clanton_v0.7.5/yocto_build/tmp/work/i586-poky-linux/attr/2.4.46-r4/attr-2.4.46/getfattr/getfattr.c:375: undefined reference to `libintl_gettext'
/home/peter/devel_gal/meta-clanton_v0.7.5/yocto_build/tmp/work/i586-poky-linux/attr/2.4 ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-01-21 14:40:13 -0500

Hi,

Are you talking about this tutorial http://wiki.ros.org/IntelGalileo/How%20to%20install%20ROS%20Hydro%20on%20Intel%20Galileo ?

I think the libintl stuff comes from libc6. Make sure this is in your ../meta-clanton-distro/recipes-core/images/image-full.bb file:

IMAGE_INSTALL += "libc-dev libstdc++-dev"
IMAGE_INSTALL += "libc6-dev"

Please let me know if it works out... I think I need help testing out the tutorials.

-Jon

edit flag offensive delete link more

Comments

Hey Jon, thanks for the answer, it was your guide. We eventually fixed it I think. One comment my colleague who's working on it said is that it seemed to work better if you added the ROS stuff after changing the image, similar to how you used to have it? Thanks for the tutorial tho! It's great!

r2djoe gravatar image r2djoe  ( 2014-01-21 20:55:50 -0500 )edit

I'm not sure i'm following what you're saying... but I did notice that if you built it before changing the distro to "clanton-full", it wouldn't work unless you delete all the files and start over again.

Jon Stephan gravatar image Jon Stephan  ( 2014-01-22 12:12:24 -0500 )edit

Indeed, there was that, and there was also a bit about commenting out the libiconv bit which I figured out myself. That was as far as we got, but then you changed the guide and it worked. Thanks!

r2djoe gravatar image r2djoe  ( 2014-01-22 20:22:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2014-01-07 03:49:21 -0500

Seen: 374 times

Last updated: Jan 21 '14