Ask Your Question
1

COB in RVIZ without meshes

asked 2011-10-11 23:20:13 -0500

ZdenekM gravatar image

updated 2011-10-19 20:48:42 -0500

Hello,

I'm working with COB (Care-O-Bot) simulations. Unfortunately my computer doesn't have enough RAM so I'm running Gazebo headless (without this feature simulation eats all my memory). But when I run RVIZ there is incomplete robot model - without meshes as you can see in first picture.

export ROBOT=cob3-2
export ROBOT_ENV=ipa-kitchen
export SIMX=-r
roslaunch cob_bringup sim.launch

image description

My question - is it caused by running Gazebo headless or is there different problem?

I tried to put just URDF model into Gazebo empty world and meshes are in their place... Used commands:

rosrun xacro xacro.py cob3-2.urdf.xacro > cob.urdf
roslaunch gazebo_worlds empty_world.launch
rosrun gazebo spawn_model -file cob.urdf -urdf -model cob3-2

image description

I'm going to buy more memory of course but now I'm curious about this problem so any information will be appreciated.

UPDATE: Ogre.log, output of system_info.sh

edit retag flag offensive close merge delete

Comments

If you run Gazebo with it's GUI, does it fix the problem in Rviz?
DimitriProsser gravatar image DimitriProsser  ( 2011-10-12 01:17:59 -0500 )edit
No. I add third image showing how robot looks when running Gazebo with GUI and spawned urdf model.
ZdenekM gravatar image ZdenekM  ( 2011-10-12 01:33:38 -0500 )edit
This makes me feel like it's not a headless Gazebo problem. In the third image, you have an error on your Robot Model in Rviz. What is that error?
DimitriProsser gravatar image DimitriProsser  ( 2011-10-12 01:36:46 -0500 )edit
I see... Ups. I think that it doesn't makes sense to run RVIZ in case if there is just model spawned in Gazebo. So I will remove third image again :-)
ZdenekM gravatar image ZdenekM  ( 2011-10-12 01:46:19 -0500 )edit
Some code has been added so it should be now more clear what I'm doing.
ZdenekM gravatar image ZdenekM  ( 2011-10-12 01:54:04 -0500 )edit
what kind of graphics card does your laptop have?
hsu gravatar image hsu  ( 2011-10-12 04:40:50 -0500 )edit
I'm using Intel integrated card. Maybe it could be reason... I tried to run erratic demo - robot also looks ok in Gazebo and not very well in RVIZ.
ZdenekM gravatar image ZdenekM  ( 2011-10-12 22:42:25 -0500 )edit
As far as I know there are some issues with Ogre3D (which rviz is built on) and Intel graphics cards. I'm not sure where, but somewhere there should be an ogre.log file from rviz. Maybe that can tell you more.
LiMuBei gravatar image LiMuBei  ( 2011-10-19 20:19:17 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-10-19 21:00:47 -0500

ZdenekM gravatar image
http://www.ogre3d.org/tikiwiki/Hardware - so the problem is caused by Intel graphics which is not (well) supported by Ogre 3D.
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-10-11 23:20:13 -0500

Seen: 399 times

Last updated: Oct 19 '11