Ask Your Question
0

how to create new data for ar_pose

asked 2014-01-01 21:55:02 -0500

chao gravatar image

updated 2014-01-28 17:06:32 -0500

ngrennan gravatar image
  1. I would like to ask if the bagfiles in open for public. Cause the access deny when i tried to download the files.

  2. I am now trying to calibrate my camera (Logitech Carl Zeiss Tessar) under calib_camera2 from artoolkit, it shows the following error

    Using supplied video config string [-width=640 -height=480].
    

    ioctl failed

    init(): Unable to open connection to camera.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-01-02 14:32:32 -0500

fergs gravatar image

See https://github.com/LucidOne/ar_tools/pull/4 for a way to fix the access denied problem (the repository has moved)

edit flag offensive delete link more
1

answered 2014-01-01 23:52:42 -0500

davinci gravatar image

updated 2014-01-01 23:53:16 -0500

2. Why not use the standard ROS camera calibration? http://wiki.ros.org/camera_calibration

edit flag offensive delete link more

Comments

cos i am prompted to enter "camera parameter filename(Data/camera_para.dat)" when i am running ./mk_patt under the artoolkit. If i ignore the prompt and continue, it gave me an error message "Using supplied video config string [-width=640 -height=480]. ioctl failed setupCamera(): Unable to open connection to camera. main(): Unable to set up AR camera."

chao gravatar image chao  ( 2014-01-02 00:31:04 -0500 )edit

so i suppose that i will need the calibration file in dat format? and do you know why i am getting that error (unable to open connection to camera)?

chao gravatar image chao  ( 2014-01-02 00:32:11 -0500 )edit

You are able to view images from the camera using the driver? I just used the marker in ~/ros/stacks/ccny-ros-pkg/ccny_vision/artoolkit/build/artoolkit-svn/patterns/pattHiro.pdf

davinci gravatar image davinci  ( 2014-01-02 02:41:06 -0500 )edit

no, the process stops after the error. i am using pattHiro as well. but when i launch the ar_pose_single.launch as suggested in the tutorial, it can't detect anything. so, i am not sure if the training data "data/4x4/4x4_1.patt" used in default is the correct data or not?

chao gravatar image chao  ( 2014-01-02 15:28:04 -0500 )edit

btw, it shows **unable to set control: Input/output error ** ERROR: could not set some settings. ** unable to set control ** when i am launch ar_pose_single.launch. will it affect the process with improper settings maybe?

chao gravatar image chao  ( 2014-01-02 16:49:57 -0500 )edit

i managed to solve the problem by using 4x4_384_1.gif in ar_pose/data/4x4 folder with the default ar_pose_single.launch that using 4x4_1.patt. and indeed the "unable to set control: Input/output error" will affect the result. when i am launching it thru another driver, which don't give me the same error, is able to track the marker easier, and the image provided by this is exposed more (more pale in general)

chao gravatar image chao  ( 2014-01-02 17:29:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-01 21:55:02 -0500

Seen: 521 times

Last updated: Jan 02 '14