ardrone not detecting tags [closed]

asked 2013-12-29 00:50:07 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.


i hope someone could help with ardrone tag recognition. I am subscribing ardrone/navdata in my code and i receive all values except for the tag detection values, which are always 0 or empty. When i echo this topic from my terminal it seems as if my drone is not recognizing them at all. I have these orange/green stripes as tags and an ardrone 2.0. Do i need to calibrate the camera or something like this? (I am using ardrone_autonomy)

I'd be glad if someone could help me! (And sorry for my english ;))

(Oh i have marked this post as a wiki.. how do i delete this? XD)

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2016-11-09 13:19:31.540651


Has anyone got an idea of what is wrong?

Cookie gravatar image Cookie  ( 2014-01-01 20:01:36 -0500 )edit

I changed the enemy_color in the launch-file and tried it this way, but nothing happened. I really need your help :( Is my drone broken maybe? Anyone help me plz :/

Cookie gravatar image Cookie  ( 2014-01-14 18:28:09 -0500 )edit

I hope we can get an answer for this problem. I am also having the same problem. All the parameters for tag detection seems correct. The drone detects tags on iphone app. But not on ROS. Also tried the ready package available on robohub but no chance. Detected tag number and tag positions are always 0 never updated.

hee502 gravatar image hee502  ( 2014-08-12 14:13:49 -0500 )edit