Ask Your Question
2

Electric Turtle install fails on ARM, Ubuntu 11.04

asked 2011-09-25 18:29:20 -0500

tonuonu gravatar image

updated 2014-01-28 17:10:26 -0500

ngrennan gravatar image

I am not first time user and older ROSes installed many times. Now installing new clean environment on Pandaboard (ARM), Ubuntu 11.04, Electric Turtle it complains often about missing dependencies. I prefer installing from source but also tried binary install. Both fail on ARM. There are no binary packages for ARM in repo I think.

Cannot copy-paste right now but it clearly looks up stuff from ROS repository. Many things are missing but for example it looks for OpenCV-2.3.1 svn something which is not by default with Ubuntu. Old ROS installed OpenCV from tar.gz, new one looks for prepackaged binary and fails.

Tried adding related repository as "deb" and "deb-src" into sources.list but nothing went better. Yes I did apt-get update :).

I hope someone already knows simple way to solve this. Should be common problem.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2011-09-26 07:15:40 -0500

tfoote gravatar image

Not all ROS packages are available in the ARM architectures. See the debbuild status page and look at the armel columns. Anything white is available.

Each stack needs to be verified and updated to be armel compatible. There are approximately 20 stacks which are building on armel at the moment.

One of the biggest limiting factors is that many of the system dependencies also are not released for the armel infrastructure. So beyond the core system you are going to need to build things from source. Patches are appreciated to extend the number of stacks supported on armel.

edit flag offensive delete link more

Comments

So no solution except waiting?
tonuonu gravatar image tonuonu  ( 2011-10-03 19:18:17 -0500 )edit
I was going to suggest looking at the build log to see what was breaking, but it seems it's a 404 for some reason: http://build.willowgarage.com/job/debbuild-build-debs-electric-natty-armel
Asomerville gravatar image Asomerville  ( 2011-10-04 05:50:38 -0500 )edit
http://www.ros.org/debbuild/electric.html does not list ARM anymore at all. Is ARM support dead completely?
tonuonu gravatar image tonuonu  ( 2011-10-23 17:28:33 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-09-25 18:29:20 -0500

Seen: 410 times

Last updated: Oct 03 '11