Ask Your Question
0

Library roscpp does not load

asked 2013-12-22 00:57:11 -0600

Hi there,

I tried to install ROS on a x86 based embedded system (Linux installed using the meta-ros layer for yocto).

In genereal (with python libraries only) it works fine.

Unfortunately I observed a strange behavior with libroscpp.so . My initial issue has been that after starting roscore, everything was up and running besides rosout. I tried to restart it manually, but the shell just blocks after calling rosout and with top I could observe that the process already stopped.

I did some tests afterwards, and wrote a small program, that does not use ROS at all. If I link it with libroscpp I get the same strange behavior as with rosout. When I leave libroscpp out, no issue at all. I can even link librostime... It is only libroscpp that creates the troubles.

I already checked with ldd all libraries that are additionally linked to my executable, and in general they are all on the harddisk...

Any ideas what I could try as next steps? As it is already the linking that causes the trouble, I am running a bit out of ideas, what to try...

Best regards Christoph

edit retag flag offensive close merge delete

Comments

Please provide actual error outputs otherwise it's very hard to help you.

tfoote gravatar imagetfoote ( 2013-12-26 18:00:31 -0600 )edit

There is no error. The moment I link libroscpp with an executable, the executable will not start. :-(

Christoph gravatar imageChristoph ( 2014-04-18 05:33:14 -0600 )edit

What do you mean it will not start? Can you show the console output?

tfoote gravatar imagetfoote ( 2014-04-18 07:20:00 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-12-22 05:07:24 -0600

VC gravatar image

Hi. I am not sure if this could be the problem you are facing, but I came across something similar with rosconsole messages - a third party library using its own version of log4cxx wasn't playing good with rosconsole, resulting in rosconsole messages being displayed wrongly. In short, is it possible that there is some mismatch in the version of other system libraries that you have linked ROS against? HTH.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-12-22 00:57:11 -0600

Seen: 133 times

Last updated: Dec 22 '13