Ask Your Question
1

boost not found in electric on Linuxmint 9(based on lucid 10.04)

asked 2011-09-13 17:16:03 -0500

morrowsend gravatar image

updated 2014-01-28 17:10:23 -0500

ngrennan gravatar image

I'm running the installations and tutorial for building packages in electric (http://www.ros.org/wiki/ROS/Tutorials/BuildingPackages) When I run the command:

rosdep install turtlesim

I get the following result:

Invalid identifier found [lucid] when processing rosdep boost.  
{{{
{'lucid': {'apt': {'packages': ['libboost1.40-all-dev']}}, 'maverick': {'apt': {'packages': ['libboost1.42-all-dev']}}, 'natty': {'apt': {'packages': ['libboost1.42-all-dev']}}}
}}}

Failed to find rosdep boost for package turtlesim on OS:ubuntu version:10.04
rosdep install ERROR:
failed to install boost

I've looked in synaptic and I have libboost1.40-all-dev installed.

I've tried the following with the following results:

  1. I've tried installing the newest version of LinuxMint in a virtual machine, but I get the same error.
  2. Installing Ubuntu 10.04 in a virtual machine. I don't get this error (however, I can't run stage because it won't work with the virtual video card).
  3. Installing ROS on a Mac, this won't work because I get a whole host of problems cropping up such as not being able to py26-setuptools, or easy_install because they are "not found" when I try sudo port install py26-setuptools)

This is driving me completely nuts. Does anyone have any idea what I can try?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2011-09-14 05:40:28 -0500

joq gravatar image

There have been a couple of other Linux Mint problems reported.

The rosdep OS detection algorithm currently treats each Linux Mint release as an alias of the corresponding Ubuntu release. But apparently, there are enough differences for problems to arise.

For this to work smoothly, some Linux Mint users may need to contribute rosdep patches for full Linux Mint OS support.

edit flag offensive delete link more
1

answered 2011-09-13 23:04:09 -0500

Lorenz gravatar image

Are you installing turtlesim from source? In that case, does rosmake turtlesim throw an error?

Maybe rosdep has problems detecting your operating system correctly. If turtlesim builds, I think you can safely ignore the rosdep error.

edit flag offensive delete link more

Comments

I ran 'rosmake turtlesim' and it compiled with no errors. The tutorial was just to get me up to speed to run a colleague's code. It fully compiles as well when I run rosmake on it, even though the other warnings pop up (like the boost one I posted, and similarly for libeigen3). Thanks for the help
morrowsend gravatar imagemorrowsend ( 2011-09-14 08:59:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-09-13 17:16:03 -0500

Seen: 514 times

Last updated: Sep 14 '11