Ask Your Question
0

fail to "roslaunch pi_tracker skeleton.launch"

asked 2011-09-12 19:57:24 -0500

ychua gravatar image

Hi, I'm not able to "roslaunch pi_tracker skeleton.launch"

SUMMARY

PARAMETERS * /use_sim_time * /skeleton_tracker/fixed_frame * /skeleton_tracker/load_filepath * /skeleton_tracker/holonomic * /skeleton_tracker/skel_to_joint_map/right_shoulder * /skeleton_tracker/tracking_rate * /skeleton_tracker/skel_to_joint_map/right_hip * /skeleton_tracker/command_rate * /skeleton_tracker/skel_to_joint_map/left_foot * /skeleton_tracker/skel_to_joint_map/left_elbow * /skeleton_tracker/skel_to_joint_map/right_foot * /skeleton_tracker/use_real_robot * /skeleton_tracker/skel_to_joint_map/right_knee * /skeleton_tracker/skel_to_joint_map/left_shoulder * /skeleton_tracker/scale_drive_speed * /skeleton_tracker/base_controller_rate * /skeleton_tracker/skel_to_joint_map/left_knee * /skeleton_tracker/base_control_side * /rosdistro * /robot_description * /skeleton_tracker/skel_to_joint_map/head * /skeleton_tracker/max_rotation_speed * /rosversion * /skeleton_tracker/skel_to_joint_map/torso * /skeleton_tracker/skel_to_joint_map/right_hand * /skeleton_tracker/skel_to_joint_map/right_elbow * /skeleton_tracker/default_joint_speed * /skeleton_tracker/max_drive_speed * /skeleton_tracker/scale_rotation_speed * /robot_state_publisher/publish_frequency * /skeleton_tracker/reverse_rotation * /skeleton_tracker/skel_to_joint_map/neck * /skeleton_tracker/skel_to_joint_map/left_hand * /skeleton_tracker/joint_controller_rate * /skeleton_tracker/skel_to_joint_map/left_hip

NODES / robot_state_publisher (robot_state_publisher/state_publisher) kinect_base_link (tf/static_transform_publisher) kinect_base_link1 (tf/static_transform_publisher) kinect_base_link2 (tf/static_transform_publisher) kinect_base_link3 (tf/static_transform_publisher) skeleton_tracker (pi_tracker/skeleton_tracker) base_world_broadcaster (tf/static_transform_publisher)

auto-starting new master process[master]: started with pid [28728] ROS_MASTER_URI=http://localhost:11311

setting /run_id to 9cae2868-dddc-11e0-9c14-00256438dd8a process[rosout-1]: started with pid [28741] started core service [/rosout] process[robot_state_publisher-2]: started with pid [28748] process[kinect_base_link-3]: started with pid [28750] process[kinect_base_link1-4]: started with pid [28756] process[kinect_base_link2-5]: started with pid [28757] process[kinect_base_link3-6]: started with pid [28760] process[skeleton_tracker-7]: started with pid [28770] process[base_world_broadcaster-8]: started with pid [28776]

[skeleton_tracker-7] process has died [pid 28770, exit code -11]. log files: /home/yuanwei/.ros/log/9cae2868-dddc-11e0-9c14-00256438dd8a/skeleton_tracker-7*.log

Any ideas to solve this? Do I need change anything in the SamplesConfig.xml or skeleton.launch?

edit retag flag offensive close merge delete

Comments

Note: "process has died [pid 28770, exit code -11]. log files: /home/yuanwei/.ros/log/9cae2868-dddc-11e0-9c14-00256438dd8a/skeleton_tracker-7*.log" --> please check this file (and post it if you need more help).
fergs gravatar image fergs  ( 2011-09-12 21:01:51 -0500 )edit
[roscpp_internal] [2011-09-14 09:00:13,929] [thread 0xb2c14790]: [DEBUG] UDPROS server listening on port [42855] [roscpp_internal] [2011-09-14 09:00:13,933] [thread 0xb2c14790]: [DEBUG] Started node [/skeleton_tracker], pid [882], bound on [yuanwei-desktop], xmlrpc port [45499], tcpros port [33642], logging to [/home/yuanwei/.ros/log/e6c36702-de6c-11e0-9b50-00256438dd8a/skeleton_tracker-7.log], using [real] time [roscpp_internal] [2011-09-14 09:00:14,196] [thread 0xb2c07b70]: [DEBUG] Accepted connection on socket [7], new socket [16] [roscpp_internal] [2011-09-14 09:00:14,197] [thread 0xb2c07b70]: [DEBUG] TCPROS received a connection from [10.217.130.120:33589] [roscpp_internal] [2011-09-14 09:00:14,197] [thread 0xb2c07b70]: [DEBUG] Connection: Creating TransportSubscriberLink for topic [/rosout] connected to [callerid=[/rosout] address=[TCPROS connection to [10.217.130.120:33589 on socket 16]]] Here's the log file but I'm still not sure what's wrong
ychua gravatar image ychua  ( 2011-09-13 13:03:37 -0500 )edit
I've also inserted <License vendor="PrimeSense" key="0KOIk2JeIBYClPWVnMoRKn5cdY4="/> in the SampleConfig.xml. But I have the same error [skeleton_tracker-7] process has died [pid 28770, exit code -11]
ychua gravatar image ychua  ( 2011-09-13 15:47:42 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-09-15 15:01:59 -0500

ychua gravatar image

It's solved now. I just svn checkout http://pi-robot-ros-pkg.googlecode.com/svn/trunk/pi_tracker. And it just mysteriously worked!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-09-12 19:57:24 -0500

Seen: 395 times

Last updated: Sep 15 '11