Ask Your Question
0

How to stop stageros from publishing its transforms?

asked 2011-09-12 17:07:18 -0500

PKG gravatar image

How can I stop stageros from publishing its transforms and all of its published topics? Is there a simple remapping possible?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2011-09-12 17:10:29 -0500

Brian Gerkey gravatar image

updated 2011-09-13 12:51:34 -0500

stage's published topics (including tf) aren't in a namespace, so you can't remap them in them one go. But you can remap them individually using the usual remapping arguments.

E.g., at the command-line (assuming one robot):

roscd stage     
./bin/stageros odom:=stage/odom base_scan:=stage/base_scan tf:=stage/tf world/willow-erratic.world

Out of curiosity, why do you want to remap stage's outputs?

edit flag offensive delete link more

Comments

My config files are meant to run on a physical robot and they publish all needed topics and transforms. To debug certain issues, I thought it a good idea to see how the same thing runs in simulation on stage. Hence I need to quench out all topics published by stageros.
PKG gravatar imagePKG ( 2011-09-12 18:03:01 -0500 )edit
Do I need to do something like : <remap from="odom" to="old_odom"/> and set tf_prefix ="old_transform" within the launch file? There's only 1 robot running.
PKG gravatar imagePKG ( 2011-09-12 18:06:32 -0500 )edit
For a launchfile you can just set the namespace to stage once using the ns attribute.
dornhege gravatar imagedornhege ( 2011-09-13 23:28:48 -0500 )edit
I tried that, and found that `/tf` was still published in the global namespace. That probably ought to be ticketed.
Brian Gerkey gravatar imageBrian Gerkey ( 2011-09-14 17:16:26 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-09-12 17:07:18 -0500

Seen: 310 times

Last updated: Sep 13 '11