Ask Your Question
2

Unmet dependency problem while installing electric: "but it is not going to be installed"

asked 2011-09-06 20:20:34 -0500

PriyankaP gravatar image

updated 2011-10-19 15:12:15 -0500

While installing ROS as per the given steps in your installation page i get the following errors:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-electric-desktop-full : Depends: ros-electric-eigen (= 1.6.0-s1313699079~maverick) but it is not going to be installed
                             Depends: ros-electric-geometry-tutorials (= 0.1.3-s1313706668~maverick) but it is not going to be installed
                             Depends: ros-electric-orocos-kinematics-dynamics (= 0.2.1-s1313699114~maverick) but it is not going to be installed
                             Depends: ros-electric-slam-gmapping (= 1.2.3-s1313706090~maverick) but it is not going to be installed
                             Depends: ros-electric-stage (= 1.4.0-s1313719635~maverick) but it is not going to be installed
                             Depends: ros-electric-visualization (= 1.6.1-s1313713150~maverick) but it is not going to be installed
                             Depends: ros-electric-vision-opencv (= 1.6.1-s1313699739~maverick) but it is not going to be installed
                             Depends: ros-electric-perception-pcl (= 1.0.0-s1313700388~maverick) but it is not going to be installed
                             Depends: ros-electric-geometry-experimental (= 0.2.2-s1313719167~maverick) but it is not going to be installed
                             Depends: ros-electric-image-pipeline (= 1.6.1-s1314697358~maverick) but it is not going to be installed
                             Depends: ros-electric-simulator-gazebo (= 1.4.2-s1314474209~maverick) but it is not going to be installed
                             Depends: ros-electric-simulator-stage (= 1.4.0-s1313719804~maverick) but it is not going to be installed
                             Depends: ros-electric-geometry-visualization (= 0.1.1-s1313732545~maverick) but it is not going to be installed
                             Depends: ros-electric-common-tutorials (= 0.1.2-s1313711126~maverick) but it is not going to be installed
                             Depends: ros-electric-image-transport-plugins (= 1.4.1-s1313699851~maverick) but it is not going to be installed
                             Depends: ros-electric-robot-model (= 1.6.0-s1313702270~maverick) but it is not going to be installed
                             Depends: ros-electric-visualization-tutorials (= 0.2.3-s1313733438~maverick) but it is not going to be installed
                             Depends: ros-electric-geometry (= 1.6.0-s1313699261~maverick) but it is not going to be installed
                             Depends: ros-electric-laser-pipeline (= 1.2.0-s1313704346~maverick) but it is not going to be installed
                             Depends: ros-electric-navigation (= 1.6.1-s1313705483~maverick) but it is not going to be installed
E: Broken packages

i'm new to ROS. please help?

edit retag flag offensive close merge delete

Comments

There is a problem with your ubuntu packages. Can you check that your packages are up2date (sudo apt-get update) and that you enabled universe/multiverse and security updates?
dornhege gravatar image dornhege  ( 2011-09-06 22:18:43 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
13

answered 2011-09-11 20:35:36 -0500

Ben_S gravatar image

Hi there, I had exactly the same problem on Ubuntu natty (11.04) and was finally able to solve it. In my case there was a conflict with libeigen3-dev which didnt match the expected version (Depends: libeigen3-dev (= 3.0.1-1+ros4~natty) but 3.0.2-3+natty1 is to be installed). I found the solution here (japanese) using google translate. I had to:

  • Uninstall pcl and eigen: Sudo apt-get remove libpcl-1.1 libeigen3-dev

  • Comment out all lines in: /etc/apt/sources.list.d/v-launchpad-jochen-sprickerhof-de-pcl-natty.list (may be maverick for you)

  • Run: sudo apt-get update

  • Install the ros-electric-desktop-full

Hope that helps.

edit flag offensive delete link more

Comments

@Ben_S Works as a dream ! .... Cheerio
Arkapravo gravatar image Arkapravo  ( 2012-01-29 02:20:52 -0500 )edit

After doing this, is one able to then reinstall Eigen and PCL easily? I would not like to break my PCL installation, which I use daily, for a whim with ROS.

BillCheetham gravatar image BillCheetham  ( 2012-02-27 22:35:48 -0500 )edit

@BillCheetham No, Update manager blocks PCL installation/updation - however that doesn't bother me !

Arkapravo gravatar image Arkapravo  ( 2012-02-27 23:07:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2011-09-06 20:20:34 -0500

Seen: 2,102 times

Last updated: Apr 19 '12