Ask Your Question
0

build error link.h:42:21: fatal error: tinyxml.h: No such file or directory

asked 2011-08-29 05:01:10 -0600

Wouter gravatar image

Dear all,

I am trying to perform the arm navigation tutorials. Therefore some packages have to be rosmaked. During compilation I constantly get this error:

home/wouter/ros/workspace/robot_model/urdf_interface/include/urdf_interface/link.h:42:21: fatal error: tinyxml.h: No such file or directory

Indeed tinyxml.h is not in /include/urdf_interface/ and therefore I copied it from /home/wouter/ros/workspace/robot_model/colladadom/build/colladadom/dom/external-libs/tinyxml.h. Nevertheless I still get this error, does anyone has a solution for this?

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
2

answered 2011-08-29 05:26:10 -0600

egiljones gravatar image

Hi,

Which arm_navigation tutorials are you trying to use? For the electric arm_navigation tutorials there should be no need to compile code - just use the debians. If you are trying to use the diamondback tutorials just use the diamondback debians. If you need to compile code for some reason in order for us to help you will have to tell us what OS you are using, what versions you are trying to install - what portion from debians, which debians, and how you've overlayed the code to compile. Given that you are using urdf_interface I gather that you are trying to use electric - just follow these instructions for ubuntu - http://www.ros.org/wiki/electric/Installation/Ubuntu

tinyxml is included in the package tinyxml - you will not just be able to bring in a header file from some other location.

edit flag offensive delete link more
0

answered 2011-08-29 06:13:44 -0600

egiljones gravatar image

I would definitely start with installing electric and doing the electric arm_navigation tutorials, especially if you interested in getting Willow Garage's arm_navigation code working with your arm. There are new tools in electric designed to get things working quickly and easily, whereas in diamondback the process was much more difficult. All of the tools should work with debians without need for code overlays.

Let us know if you have any problems, and I'll be interested to see how the tools work with a 9-dof arm - I haven't tried anything higher than 7-dof.

edit flag offensive delete link more
0

answered 2011-08-29 06:09:45 -0600

Wouter gravatar image

Thanks for your quick reply! I indeed forgot to list my OS. I am using diamondback on Ubuntu 11.04. If I understand you correctly I should first install ROS electric before I can use electric tutorials.

I would like to do all arm_navigation tutorials such that I get a good background for motion planning and collision detection on my 9 DOF manipulator. I am quite new to motion planning.

I have created a rosinstall overlay on home/ros and on home/ros/workspace

edit flag offensive delete link more
0

answered 2011-08-29 06:20:14 -0600

Wouter gravatar image

Thanks for your advice again. Also good to know that it has been tested up untill 7-dof. I will let you know if whether I get it to work.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-08-29 05:01:10 -0600

Seen: 1,959 times

Last updated: Aug 29 '11