ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

How to build an installed package?

asked 2013-12-14 05:15:28 -0600

dinomoracs gravatar image

Hi,

I have installed ROS Hydro version (full install) and MoveIt!. In the /opt/ros/hydro/share folder there are many installed packages (e.g. /moveit_ros_benchmarks) but I can't find what it is supposed to be. In almost every folder there are only:

-/cmake (with two .cmake files inside) -package.xml

I tried to build it to get the files needed, following the "building packages" ROS tutorials but it didn't work. I also re-installed desired packages from source with no change. So I don't know if I'm having some issues with the packages building or with rights to build in that location. I'm expecting the package shown in the benchmarking tutorial in the Moveit! wiki, with "moveit_benchmark_statistics.py" or "run_benchmark_ompl.launch" files in it.

Thank you!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-12-16 06:30:22 -0600

Dirk Thomas gravatar image

The file is part of the source repository (https://github.com/ros-planning/moveit_ros/blob/hydro-devel/benchmarks/benchmarks/scripts/moveit_benchmark_statistics.py) but is currently not being installed correctly. This is a bug in the released Debian package (I filled https://github.com/ros-planning/moveit_ros/issues/389).

You can either wait for a fix to be released by the maintainers or checkout the source repository and compile the package on your own (without installing it).

edit flag offensive delete link more
0

answered 2013-12-15 22:03:19 -0600

felix k gravatar image

updated 2013-12-15 22:06:57 -0600

You cannot and never should try to build anything ROS-related with sudo, which includes building in /opt etc. Packages installed via apt have to be built already.

I know that the folders you find as packages are somewhat empty, which is because with the new catkin system all ros-executables are in one folder, headers in another etc. I don't have the exact wiki page explaining all this at hand.

What's the issue, again? Have you tried rosrun moveit...package moveit_benchmark_statistics.py or roslaunch respectively?

edit flag offensive delete link more

Comments

With both rosrun and roslaunch I get an error: "[moveit_benchmark_statistics.py] is neither a launch file in package [moveit_ros_benchmars] nor is [moveit_ros_benchmars] a launch file name" I also searched in /opt but the file "moveit_benchmark_statistics.py" doesn't exist. Thanks!

dinomoracs gravatar image dinomoracs  ( 2013-12-15 22:20:03 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2013-12-14 05:15:28 -0600

Seen: 401 times

Last updated: Dec 16 '13