Ask Your Question
0

hokuyo node not running

asked 2011-08-25 04:28:28 -0500

natan gravatar image

updated 2011-08-25 05:45:25 -0500

dornhege gravatar image

cant run hokuyo node output

natan@natan-ThinkPad-T60:~$ rosdep install hokuyo_node rviz
Warning: could not identify ['hokuyo_node'] as a package
rosdep executing this script:
{{{
set -o errexit
#No Packages to install
}}}

what am i missing

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-08-25 05:50:52 -0500

dornhege gravatar image

In short: You are missing the hokuyo_node package. (Also rosdep install does not run the hokuyo node, rosrun does.)

This could be either because it is not installed (then you need to install it) or your ROS_PACKAGE_PATH environment variable is not containing the directory for the hokuyo_node.

Did you install diamondback from packages? Then you should have /opt/ros/diamondback/stacks/laser_drivers/hokuyo_node. If that is the case source /opt/ros/diamondback/setup.sh and roscd hokuyo_node should work. If it is not there you need to install ros-diamondback-laser-drivers.

Otherwise, you need to give some more information on your system and ROS setup.

edit flag offensive delete link more

Comments

i do not hav /opt/ros/diamondback/stacks/laser_drivers/hokuyo_node. how do i add it??
natan gravatar image natan  ( 2011-08-25 06:46:00 -0500 )edit
sudo apt-get install ros-diamondback-laser-drivers
Lorenz gravatar image Lorenz  ( 2011-08-25 06:57:44 -0500 )edit
thx lorenz workes
natan gravatar image natan  ( 2011-08-25 07:05:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-08-25 04:28:28 -0500

Seen: 688 times

Last updated: Aug 25 '11