Ask Your Question
0

cannot install neither electric nor unstable

asked 2011-08-16 21:32:37 -0500

Moataz Elmasry gravatar image

updated 2014-01-28 17:10:13 -0500

ngrennan gravatar image

Hello list

I use ubuntu 10.04(lucid) 64 bit. I have been using diamondback for a while with no problems Due to some new code I need, which does not exist on diamondback, I tried to upgrade to unstable, so I removed all the diamondback stacks using synaptic and installed unstable one day after, ubuntu reported a partial upgrade regarding the ros unstable stacks. After that partial upgrade, some packages have been removed and could not be installed. I get the error msg: "error dependancy ros-unstable-opencv, but it cannot be installed" Among these packages are: ros-unstable-opencv ros-unstable-image-pipeline ros-unstable-simulator Same problem happens with ros-electric I had to revert back to diamondback Anyone else having problems installing either electric or unstable short ago?

Best regards

edit retag flag offensive close merge delete

Comments

I investigated further into the problem. Tits a dependancy problem and is caused by unmatched version of opencv. This is the error message I get when installing ros-unstable-vision-opencv: ros-unstable-vision-opencv: Depends: libopencv2.3-dev (=2.3.1+svn6514+branch23-1~lucid) but 2.3.0+svn5720+trunk-5~lucid is to be installed
Moataz Elmasry gravatar image Moataz Elmasry  ( 2011-08-16 23:42:49 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-08-17 03:34:55 -0500

kwc gravatar image

This should be resolved now if you run 'apt-get update'

edit flag offensive delete link more

Comments

Thnx for the reply. I tried to make an update, no new packages appear, I live in germany, so I changed the repository server to USA server (not that it should matter), and still got no updates
Moataz Elmasry gravatar image Moataz Elmasry  ( 2011-08-17 03:52:44 -0500 )edit
Did you run "sudo apt-get update" after you changed the repository? I was able to update on my machine. Also, not sure what you mean by 'USA' server as we only run 1 server. You need packages.ros.org/ros as your repository.
kwc gravatar image kwc  ( 2011-08-17 03:56:24 -0500 )edit
sorry about the 'USA' server, for a minute I thought ros packages are being pulled from the ubuntu server, my mistake
Moataz Elmasry gravatar image Moataz Elmasry  ( 2011-08-17 04:10:59 -0500 )edit
so, do you still get the opencv error?
kwc gravatar image kwc  ( 2011-08-17 04:12:34 -0500 )edit
nop.I was using the freiburg repo, now I switched to the main ros repo, and I can install ros unstable like charm. Many thanks for the quick reaction
Moataz Elmasry gravatar image Moataz Elmasry  ( 2011-08-17 04:16:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-08-16 21:32:37 -0500

Seen: 268 times

Last updated: Aug 17 '11