Ask Your Question
0

gazebo crashes after C-c pr2_teleop

asked 2011-08-16 06:52:53 -0500

130s gravatar image

updated 2011-08-22 06:21:57 -0500

This happens every time so that I have to open gazebo and rviz (+ re-size those windows as I prefer). Since I'm just reporting the particular phenomenon & reproduction scenario I've been seeing, I don't know if this issue can be generalized. Any idea is appreciated.

Phenom:

  • Every time I C-c pr2_teleop, gazebo and rviz crash after that.

  • error msg in the terminal pr2_gazebo was opened in:

[gazebo-*2] process has died [pid 15754, exit code -11].

log files: /home/icg-dell-m6400/.ros/log/030eb44a-c82c-11e0-b04d-0026b9168399/gazebo-2*.log

[base_hokuyo_node-15] process has died [pid 15783, exit code -11].

log files: /home/icg-dell-m6400/.ros/log/030eb44a-c82c-11e0-b04d-0026b9168399/base_hokuyo_node-15*.log

[tilt_hokuyo_node-16] process has died [pid 15785, exit code -11].

log files: /home/icg-dell-m6400/.ros/log/030eb44a-c82c-11e0-b04d-0026b9168399/tilt_hokuyo_node-16*.log

[camera_synchronizer_node-18] process has died [pid 15800, exit code -11].

log files: /home/icg-dell-m6400/.ros/log/030eb44a-c82c-11e0-b04d-0026b9168399/camera_synchronizer_node-18*.log

Env: Ubuntu 10.10, ros-diamondback-all as of Aug 16, '11. Memory 3.9 GB, Intel Core 2 Duo 2.53 GHz. Dell Precision M6400. nVidia Corporation G94M [Quadro FX 2700M], OpenGL version string: 3.3.0 NVIDIA 260.19.06

Thanks.

(UPDATE ; Aug 18, 2011) Ok I tried 2 patterns of booting order below, and I found Segfault only sometimes occurs while gazebo is running with gdb. For the 1st order below, I couldn't get backtrace. Here's the result backtraced for the 2nd one. http://pastebin.com/hcBcPNpU (however bt returned only 1 line and it seems not much new info). I also updated the environment info since it might be hardware related according to the Segfault error content.

Order-1. gazebo -> teleop -> gdb -> C-c teleop (nothing special occurs) -> teleop -> C-c teleop (gazebo crashes, gdb says "No stack")

Order-2. gazebo -> gdb -> teleop -> C-c teleop (SegFault occurs) -> teleop -> Type "cont" on gdb (gazebo crashes, gdb says "No stack")

Command used to run the programs:

gazebo: roslaunch pr2_gazebo pr2_empty_world.launch

teleop: roslaunch pr2_teleop teleop_keyboard.launch

(Update Aug 22, '11) This phenom doesn't occur on my another machine that uses NVIDIA driver as well.

Env: Ubuntu 11.04, Kernel 2.6.38-11-generic, GNOME 2.32.1, nVidia Corporation Device 1251

edit retag flag offensive close merge delete

Comments

How are you starting up pr2_teleop/gazebo/rviz? make sure they are not in the same launch script. Can you get a backtrace or coredump of gazebo? (see http://www.ros.org/wiki/pr2_simulator/Tutorials/RunningSimulatorWithGDB for reference)
hsu gravatar image hsu  ( 2011-08-16 07:28:26 -0500 )edit
@hsu thanks. All of them are executed on different terminals (am I answering your question?). I've been failing to gdb and posted a new question for that (http://answers.ros.org/question/1886/gdb-says-program-is-not-being-run-upon-gazebo).
130s gravatar image 130s  ( 2011-08-16 11:44:27 -0500 )edit
@hsu Now I can dump with gdb. Here's the result. http://pastebin.com/2Z5aCmxj I see a Segmentation Fault occurs, but not yet figured out what's the root cause.
130s gravatar image 130s  ( 2011-08-18 11:05:54 -0500 )edit
@IsaacS: when you get the SegFault in GDB, type "bt" to get a backtrace and paste that here or to pastebin. The backtrace will be much more helpful than the normal startup output since it should show exactly where the segfault occurs.
Eric Perko gravatar image Eric Perko  ( 2011-08-18 11:09:48 -0500 )edit
in addition to bt output, please also pose the roslaunch commands you use to start things up. thanks.
hsu gravatar image hsu  ( 2011-08-18 11:47:20 -0500 )edit
@Eric Perko For the log with backtrace, please see the question body that I just updated. Thx
130s gravatar image 130s  ( 2011-08-18 11:48:36 -0500 )edit
@hsu I added commands I used for gazebo & teleop in the question body.
130s gravatar image 130s  ( 2011-08-18 11:57:26 -0500 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2011-08-22 07:15:26 -0500

130s gravatar image

updated 2011-08-22 09:51:10 -0500

Just a workaround. I changed the version of the driver to the older version as follows:

  • previously in use) 260.19.06 NVIDIA accelerated graphics driver (version current)
  • new) 173.14.28 NVIDIA accelerated graphics driver (version 173)

Changed by "System"->"Administration"->"Additional Drivers". Don't know what unexpected effects might happen though.

Although I'm talking about the workaround in very specific case, I hope it helps others who have similar issue.

edit flag offensive delete link more
1

answered 2011-08-18 11:09:31 -0500

hsu gravatar image

updated 2011-08-18 11:57:49 -0500

great! at the point where you see

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x863e0b70 (LWP 26134)]
0xb58e64fe in ?? () from /usr/lib/nvidia-current/libGL.so.1
(gdb) quit

instead of typing quit, type bt, e.g.:

(gdb) bt

and post the outputs. Thanks.

Looking at your log, the first segfault occurs:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x8685cb70 (LWP 5791)]
0xb58354fe in ?? () from /usr/lib/nvidia-current/libGL.so.1
(gdb) bt
#0  0xb58354fe in ?? () from /usr/lib/nvidia-current/libGL.so.1
(gdb) cont

instead of continuing as you did in the last line above, try

(gdb) info threads

and post outputs again.

By the way, you can google gdb to find out more about the debugger.

edit flag offensive delete link more

Comments

@hsu Thanks. http://pastebin.com/Qv8v54pg Now I know the root function is in Ogre. I also tried your other suggestions (turn off compiz by "System -> Preferences -> Appearance -> Visual Effects -> None", killall teleop_pr2_keyboard) but crashing still occurs. I'll try using other drivers & machines
130s gravatar image 130s  ( 2011-08-19 14:19:41 -0500 )edit
which nvidia driver are you using? nouveau?
hsu gravatar image hsu  ( 2011-08-19 14:23:32 -0500 )edit
@hsu As I added to the original question post, the problem didn't occur in another machine that uses NVIDIA GeForce 560. On the problematic machine, glxinfo returns that the driver's version is 260.19.06, not sure yet if it's nouveau as you mentioned.
130s gravatar image 130s  ( 2011-08-22 06:23:53 -0500 )edit
0

answered 2011-08-18 12:00:15 -0500

hsu gravatar image

updated 2011-08-18 12:20:40 -0500

try disabling compiz? see this post.

edit flag offensive delete link more
0

answered 2011-08-18 12:02:21 -0500

hsu gravatar image

Instead of c-c in the pr2_teleop terminal, start up another terminal, and kill the node directly

killall teleop_pr2_keyboard
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-08-16 06:52:53 -0500

Seen: 408 times

Last updated: Aug 22 '11