Ask Your Question
0

problem installing ros full ubuntu 10.4

asked 2011-08-15 22:22:45 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

the comand line end the error are

sudo apt-get install ros-diamondback-desktop-full
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-diamondback-desktop-full : Depends: ros-diamondback-ros-tutorials (= 0.2.4-s1312445230~lucid) but it is not going to be installed
                                Depends: ros-diamondback-geometry-tutorials (= 0.1.3-s1312445373~lucid) but it is not going to be installed
                                Depends: ros-diamondback-slam-gmapping (= 1.2.3-s1312435634~lucid) but it is not going to be installed
                                Depends: ros-diamondback-ros (= 1.4.9-s1312417708~lucid) but it is not going to be installed
                                Depends: ros-diamondback-visualization (= 1.4.1-s1312432000~lucid) but it is not going to be installed
                                Depends: ros-diamondback-vision-opencv (= 1.4.3-s1312425872~lucid) but it is not going to be installed
                                Depends: ros-diamondback-perception-pcl (= 0.10.0-s1312427042~lucid) but it is not going to be installed
                                Depends: ros-diamondback-rx (= 1.4.2-s1312430459~lucid) but it is not going to be installed
                                Depends: ros-diamondback-image-pipeline (= 1.4.2-s1312437407~lucid) but it is not going to be installed
                                Depends: ros-diamondback-simulator-gazebo (= 1.2.8-s1312440157~lucid) but it is not going to be installed
                                Depends: ros-diamondback-diagnostics-monitors (= 1.4.0-s1312439740~lucid) but it is not going to be installed
                                Depends: ros-diamondback-simulator-stage (= 1.2.5-s1312437801~lucid) but it is not going to be installed
                                Depends: ros-diamondback-image-common (= 1.4.1-s1312425748~lucid) but it is not going to be installed
                                Depends: ros-diamondback-common-tutorials (= 0.1.2-s1312463072~lucid) but it is not going to be installed
                                Depends: ros-diamondback-ros-comm (= 1.4.7-s1312424712~lucid) but it is not going to be installed
                                Depends: ros-diamondback-visualization-common (= 1.4.2-s1312430681~lucid) but it is not going to be installed
                                Depends: ros-diamondback-physics-ode (= 1.4.1-s1312430103~lucid) but it is not going to be installed
                                Depends: ros-diamondback-driver-common (= 1.2.3-s1312425659~lucid) but it is not going to be installed
                                Depends: ros-diamondback-executive-smach (= 1.0.2-s1312435548~lucid) but it is not going to be installed
                                Depends: ros-diamondback-common-msgs (= 1.4.0-s1312425065~lucid) but it is not going to be installed
                                Depends: ros-diamondback-image-transport-plugins (= 1.4.1-s1312426755~lucid) but it is not going to be installed
                                Depends: ros-diamondback-robot-model (= 1.4.0-s1312427974~lucid) but it is not going to be installed
                                Depends: ros-diamondback-visualization-tutorials (= 0.2.2-s1312464635~lucid) but it is not going to be installed
                                Depends: ros-diamondback-geometry (= 1.4.2-s1312425346~lucid) but it is not going to be installed
                                Depends: ros-diamondback-documentation (= 1.4.1-s1312464754~lucid) but it is not going to be installed
                                Depends: ros-diamondback-executive-smach-visualization (= 1.0.1-s1312459854~lucid) but it is not going to be installed
                                Depends: ros-diamondback-laser-pipeline (= 1.2.0-s1312429600~lucid) but it is not going to be installed
                                Depends: ros-diamondback-common (= 1.4.3-s1312425161~lucid) but it is not going to be installed
                                Depends: ros-diamondback-diagnostics (= 1.4.0-s1312425553~lucid) but it is not going to be installed
                                Depends: ros-diamondback-navigation (= 1.4.1-s1312429823~lucid) but it is not going to be installed"
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2011-08-16 00:16:25 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

You have a problem in your package sources/package install. Can you update your original post with your /etc/apt/sources.list? There should only be lucid entries in there.

Some package is "blocking" your install. To figure out the cause, you can choose one in the list, where it says "but is not going to be installed", and install only that. If you get a similar error there, continue with the package causing the next error until you get a different error.

Usually you arrive at some error that tells you it wants a package in a certain version, but it can only be installed in another one (or not at all). Post that error here.

In general you should make sure that your /etc/apt/sources.list only contains lucid entries, run apt-get update and then resolve the situation.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-08-15 22:22:45 -0500

Seen: 393 times

Last updated: Aug 16 '11