Ask Your Question
1

Problem building rosjava-core - rosjava_core:unspecified

asked 2013-12-08 00:22:09 -0500

rlsutton1 gravatar image

I'm trying to build rosjava_core by invoking ./gradlew

I'm running kubuntu 13.04, and have installed ros-hydro-desktop-full from the repos.

I've cloned rosjava_core from the git repo, and switched to the hydro branch.

this is the error I am getting.

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'rosjava_core'.
> Could not resolve all dependencies for configuration ':classpath'.
   > Could not find any version that matches org.ros.rosjava_bootstrap:gradle_plugins:[0.1,0.2).
     Required by:
         :rosjava_core:unspecified

On a side note, all I actually want to do is start writing a java node. Am I starting in the wrong place?

Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2013-12-09 04:29:52 -0500

updated 2013-12-10 00:33:22 -0500

There's a set of 3 tutorials here. The first explains the installation. You don't even need to build rosjava from source, you can get deb packages for it. If you want to do it from source, there are also a few more steps to it, as explained in the tutorial.

The following two tutorials should (in theory) get you running with your first rosjava package, but at the moment there seem to be bugs. But that's a question for another day... :)

edit flag offensive delete link more

Comments

Thank you very much, problem solved.

rlsutton1 gravatar image rlsutton1  ( 2013-12-09 13:38:22 -0500 )edit

Should be bug free - we've been using those instructions unchanged for a month or two now. If there's bugs (or perhaps missing documentation), please post!

Daniel Stonier gravatar image Daniel Stonier  ( 2013-12-09 20:57:45 -0500 )edit

@Daniel Stonier: sorry for the false alarm. I tried Tutorial 2 ("creating rosjava packages") yesterday and failed; today, it worked. Turns out I was too stupid for copy-paste, and instead of `cd rosjava_foo; catkin_create_rosjava_project dude` I did `cd rosjava; ...`. :o)

Martin Günther gravatar image Martin Günther  ( 2013-12-10 00:35:38 -0500 )edit

Awesome :)

Daniel Stonier gravatar image Daniel Stonier  ( 2013-12-11 02:34:19 -0500 )edit

I'm trying to test ROSJAVA on 12.04 with hydro, but 'Creating Rosjava Packages' in above tutorial give error

:foo_msgs:jar

FAILURE: Build failed with an exception.

* What went wrong:
Could not copy MANIFEST.MF to '/home/aknirala/rosjava/src/rosjava_foo/foo_msgs/build/tmp/jar/MANIFEST.MF'

aknirala gravatar image aknirala  ( 2013-12-16 00:55:46 -0500 )edit

Any suggestion on how to fix this? A silly question: Do I need to install gradle separately?

aknirala gravatar image aknirala  ( 2013-12-16 00:58:51 -0500 )edit

You might like to start a new question aknirala. I just took that information out of that particular tutorial so it 'works'. The next tutorial on unofficial messages is more relevant for highlighting about msg project generation.

Daniel Stonier gravatar image Daniel Stonier  ( 2013-12-16 15:09:59 -0500 )edit

Thnx, I started learning gradle (as I figure out it will be v helpful). It seems it is gradle issue, or I'll be able to easily identify it once I know gradle.... If possible please update the tutorial by adding info on what you remove to run it error free. I'll do it once I figure that out.

aknirala gravatar image aknirala  ( 2013-12-18 03:09:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-12-08 00:22:09 -0500

Seen: 1,200 times

Last updated: Dec 10 '13