Ask Your Question
0

sending goal to move_base_simple has no effect

asked 2013-12-01 10:08:56 -0600

Strav gravatar image

updated 2014-01-28 17:03:44 -0600

ngrennan gravatar image

Hi! Still getting acquainted so please be patient.

From ROS electric (have to deal with legacy code, can't upgrade), I'm trying to simply move my turtlebot around using the move_base_simple topic. At first, I tried using actionlib, succeeded in connecting to the server, setting up a goal but sending it actually had no effect. For debugging purposes, I'm now trying to simply publish the goal from command line.

Here is my current setup:

First ran:

roslaunch turtlebot_bringup minimal.launch
roslaunch turtlebot_navigation move_base_turtlebot.launch

now from rostopic list I have:

/move_base/goal
/move_base_node/current_goal
/move_base_simple/goal

I then try to publish the goal as follows:

rostopic pub /move_base_simple/goal geometry_msgs/PoseStamped '{ header: { frame_id:  "/base_link"}, pose: { position: { x: 0.2, y: 0 }, orientation: { x: 0, y: 0, z: 0, w: 1 } } }'

Nothing happens. If I try: rostopic echo /move_base_simple/goal, I can see that the goal is set. I tried changing the turtlebot_drive_mode to either drive, twist or turtle, no effect. I also tried to teleop the bot with the keyboard, it works. Tried to send velocity commands, also works.

If anyone can shed some light on why the robot isn't responding to the commands, it'll be greatly appreciated! (I've spent more than 5 hours digging on this issue).

Thanks!

edit retag flag offensive close merge delete

Comments

Could it be some problem with costmaps? Did you try to visualize them in rviz?

Tirjen gravatar imageTirjen ( 2013-12-03 04:31:54 -0600 )edit

costmaps? Forgive me if this is obvious, but I thought I could use move_base without providing any map nor transformation frame other than base_link. I am somewhat loosely following this tutorial: http://wiki.ros.org/navigation/Tutorials/SendingSimpleGoals; haven't saw anything in that code that involved a map of any kind.

Strav gravatar imageStrav ( 2013-12-03 10:43:35 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-12-03 20:19:10 -0600

Tirjen gravatar image

Honestly I never tried to use the navigation stack without a map, but I'm pretty sure it isn't possible. Moreover, reading the first line of the description of the tutorial ("The Navigation Stack serves to drive a mobile base from one location to another while safely avoiding obstacles.") makes me think so. Also in the pre-requisites is written "This tutorial assumes basic knowledge of how to bring up and configure the navigation stack.".

Take also in consideration that independently from the move_base planner, without a map and a sensor used for localization, usually any planner wouldn't work much well using only the odometry of the robot. What sensor do you have on your robot?

What I suggest you to do is to look at this tutorial and in general to all other tutorials of the navigation stack.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-12-01 10:08:56 -0600

Seen: 2,656 times

Last updated: Dec 03 '13