Ask Your Question
2

rivz/ogre crash after update

asked 2011-07-09 10:33:08 -0600

andrew-unit gravatar image

updated 2011-07-13 09:56:44 -0600

Hello, I'm running Ubuntu 10.04 LTS with the diamondback ROS release. I just upgraded my installation and now I can't seem to run rviz any more. I was running it fine like 30 minutes ago before I decided to update my system. I attached the error. I tried searching on answers but I didn't see anything immediately relevant.

andrewha@andrewha-G73s:~$ rosrun rviz rviz 

Failed to initialize Ogre: OGRE EXCEPTION(7:InternalErrorException): Could not load dynamic library Plugin_CgProgramManager.  System Error: Plugin_CgProgramManager.so: cannot open shared object file: No such file or directory in DynLib::load at /tmp/buildd/ros-diamondback-visualization-common-1.4.1/debian/ros-diamondback-visualization-common/opt/ros/diamondback/stacks/visualization_common/ogre/build/ogre_src_v1-7-1/OgreMain/src/OgreDynLib.cpp (line 91)

[ERROR] [1310250509.390105644]: Caught exception while loading: OGRE EXCEPTION(7:InternalErrorException): Could not load dynamic library Plugin_CgProgramManager.  System Error: Plugin_CgProgramManager.so: cannot open shared object file: No such file or directory in DynLib::load at /tmp/buildd/ros-diamondback-visualization-common-1.4.1/debian/ros-diamondback-visualization-common/opt/ros/diamondback/stacks/visualization_common/ogre/build/ogre_src_v1-7-1/OgreMain/src/OgreDynLib.cpp (line 91)

andrewha@andrewha-G73s:~$
edit retag flag offensive close merge delete

Comments

I'm having the same issue. Are you using the deb packages, or building independantly?
Asomerville gravatar imageAsomerville ( 2011-07-13 09:35:25 -0600 )edit

5 Answers

Sort by ยป oldest newest most voted
2

answered 2011-07-13 10:09:44 -0600

eitan gravatar image

So, it looks like something went wrong in how the debian packages were built for visualization_common in the latest diamondback release. I filed a ticket on this here, https://code.ros.org/trac/ros-pkg/ticket/5059, and the stack maintainer is looking into things. Until this is resolved, the solution seems to be to build visualization_common from source. Hope this helps.

edit flag offensive delete link more

Comments

it has been resolved. the nvidia cg packages failed silently during the build. we have rebuilt and reployed.
kwc gravatar imagekwc ( 2011-07-14 17:03:04 -0600 )edit
1

answered 2011-07-11 03:43:39 -0600

dong gravatar image

I had the same problem today. rebuild ogre in visualization_stack helps. by building Tarball seems not to work. simply uncomment the downloading lines in the Makefile

edit flag offensive delete link more
1

answered 2011-09-02 02:40:42 -0600

I upgraded my ROS installation yesterday, and this OGRE bug re-materialized.

My solution: Update my Ubuntu sources.list to packages.ros.org instead of the old code.ros.org. From the current ROS installation page:

sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu lucid main" > /etc/apt/sources.list.d/ros-latest.list'
wget http://packages.ros.org/ros.key -O - | sudo apt-key add -

Apparently the location of the packages has changed recently? Whereas the code.ros.org repos showed no new packages (after "apt-get update"), the packages.ros.org repos did. I ran a dist-upgrade using the packages.ros.org repos, which pulled down a (new?) version of the visualization libraries. This eliminated the bug. YMMV.

edit flag offensive delete link more

Comments

Lorenz gravatar imageLorenz ( 2011-09-02 02:57:52 -0600 )edit
Ha! Good to know. Somehow I missed that announcement on ros-users. Based on my experiences, it would seem that the package repositories are not quite being mirrored at this time. So everyone should update their apt sources!
Travis Deyle gravatar imageTravis Deyle ( 2011-09-02 03:04:02 -0600 )edit
1

answered 2011-07-09 11:02:19 -0600

andrew-unit gravatar image

This post helped me. I basically did a make wipe in ogre and rebuilt ogre and ogre_tools, and now I can run rviz again.

http://ros-users.122217.n3.nabble.com/rviz-installation-td766428.html

edit flag offensive delete link more

Comments

Removing and reinstalling deb packages on the other hand does not work.
Asomerville gravatar imageAsomerville ( 2011-07-13 09:41:50 -0600 )edit
0

answered 2011-07-14 04:32:32 -0600

updated 2011-07-15 01:30:07 -0600

For those using deb packages there are fixed packages here, and should be pushed soon to the standard repository:

* http://packages.ros.org/ros-shadow-fixed/ubuntu/pool/main/r/ros-diamondback-visualization-common/ * http://packages.ros.org/ros-shadow-fixed/ubuntu (they are apparently version locked and must be updated together)

Update:

The repositories should now have the fix:

edit flag offensive delete link more

Comments

I've tried both versions: for the deb package the result is: "Error: Breaks existing package 'ros-diamondback-pr2-simulator' dependency ros-diamondback-visualization-common (= 1.4.1-s1310003205~lucid)" and from the repository: "ERROR: md5sum mismatch (8a8ace938eb9921f973789d2acc1a238 != 85083083dc65d49572654ea8c8b5c552) on build/ogre_src_v1-7-1.tar.bz2; aborting".
szokei gravatar imageszokei ( 2011-07-14 21:44:43 -0600 )edit
KWC informed me that they're version locked and have to all be updated together. However the standard repositories are now updated so that's the better source.
Asomerville gravatar imageAsomerville ( 2011-07-15 01:31:56 -0600 )edit
Executing "rosmake" to the new visualization_common package will result in an infinite compilation process. Thank you.
szokei gravatar imageszokei ( 2011-07-21 18:23:28 -0600 )edit
While I could follow dongs (see answer above) resolution method, simply updating the deb packages from the repositories does still not work! Am I missing something?
Georg gravatar imageGeorg ( 2011-07-25 08:19:20 -0600 )edit
I had the same problem and updating from repositories worked for me. Make sure to run `apt-get update` before trying to update the packages.
Asomerville gravatar imageAsomerville ( 2011-07-25 11:58:09 -0600 )edit
That is really strange, of course I did `apt-get update` before, hmm. However running make in visualization_common/ogre helped.
Georg gravatar imageGeorg ( 2011-07-25 20:50:02 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-07-09 10:33:08 -0600

Seen: 1,368 times

Last updated: Sep 02 '11