Ask Your Question
0

In CentOS 5.6, unable to: hg clone https://kforge.ros.org/openni/drivers

asked 2011-06-30 08:22:24 -0500

expressoCoder gravatar image

Output from CentOS 5.6: $ hg clone https://kforge.ros.org/openni/drivers

http authorization required realm: kforge.ros.org Restricted Area user: password:

I keep getting asked for a user name and password. However cloning works fine for other https repos like: hg clone https://bitbucket.org/aragost/hello

Also works fine from Mac OS X 10.6.7 using MacPorts

Help!

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2011-06-30 20:23:58 -0500

expressoCoder gravatar image

Okay I figured out what was causing my problem.

First off, the CentOS 5.6 yum repo only has python 2.4, so you will need to manually download and install python 2.6.

Uninstall mercurial if you have previously installed it from the CentOS yum repo, because mercurial would have been installed with python 2.4 files.

Manually download the source for docutils-snapshot and install it for python-2.6. Then download mercurial 1.8.x and install it for python 2.6.

Then anonymous read-only cloning should work

edit flag offensive delete link more
0

answered 2011-06-30 17:09:38 -0500

Mac gravatar image

Have you tried an empty username and password?

edit flag offensive delete link more
0

answered 2011-06-30 20:25:16 -0500

expressoCoder gravatar image

Btw the empty username and password did not work

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-06-30 08:22:24 -0500

Seen: 983 times

Last updated: Jun 30 '11