Ask Your Question
2

Something wrong with the "Make a map" tutorial ??

asked 2013-11-24 17:58:30 -0600

zhangyong19800721@gmail.com gravatar image

updated 2013-12-12 20:09:39 -0600

tfoote gravatar image

When I follow the tutorials at "Make A Map", I execute the command "roslaunch turtlebot_gazebo turtlebot_playground.launch" in a terminal, but serveral errors are resonsed and the turtlebot environment does not appear as expected as the picture show. What happend? How can i fix it? or just this tutorial needs to be updated.

I am working with ROS-Hydro and the Ubuntu 12.04. The following are executed in a terminal: $ source /opt/ros/hydro/setup.bash \n $ export TURTLEBOT_BASE=create \n $ export TURTLEBOT_STACKS=circles \n $ export TURTLEBOT_3D_SENSOR=asus_xtion_pro \n $ roslaunch turtlebot_gazebo turtlebot_playground.launch \n

The Error is as follows: ...... Error [ModelDatabase.cc:408] Unable to download model[model://dumpster/meshes/dumpster.dae] Error [SystemPaths.cc:371] File or path does not exist[""] .... .... .... ....(Many Warnings and Errors)

edit retag flag offensive close merge delete

Comments

Which version of ROS are you using? Can you post the errors?

Tirjen gravatar imageTirjen ( 2013-11-24 19:46:22 -0600 )edit

Same issue here; models of the cylinder and bookshelf still show up but dumpster, cube_20k, and jersey_barrier are missing or have been moved. Otherwise it works fine.

Neil Traft gravatar imageNeil Traft ( 2014-05-15 08:36:49 -0600 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2013-11-25 02:17:51 -0600

Tirjen gravatar image

I can tell you that I have the same error (using ROS Hydro and the same version of Ubuntu), it seems like gazebo is unable to find and download several models that are in this world it tries to launch.

Does the launch file turtlebot_empty_world.launch work? If it works I suggest you to create your own environment (using boxes, cylinders or also other objects) and use this world for building a map.

edit flag offensive delete link more
1

answered 2014-06-26 13:58:42 -0600

2ROS0 gravatar image

updated 2014-06-26 14:38:05 -0600

Update: It works if you manually download the required models onto your computer. I found this information over here.

wget http://gazebosim.org/models/dumpster/...
tar xvf model.tar.gz -C ~/.gazebo/models

And then do the same for whichever model you want from here

I have the same error with 12.04 and Hydro. The empty world option with self-generated objects as mentioned above is a workaround but that also means we cannot use Gazebo's database of models. Hopefully, someone can make a permanent fix for this.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2013-11-24 17:58:30 -0600

Seen: 564 times

Last updated: Jun 26 '14