Ask Your Question
1

rviz is agonizingly slow

asked 2011-06-29 08:04:30 -0500

Khiya gravatar image

updated 2016-10-24 08:59:21 -0500

ngrennan gravatar image

Hello,

Are there any common reasons that would cause RVIZ to update very very slowly? I've been working with the Xbox Kinect and depth point clouds and every time I start rviz with the openni_camera node (ie, $roslaunch openni_camera openni_node.launch, $rosrun rviz rviz as suggested from the http://www.ros.org/wiki/openni_camera guide), everything on Ubuntu slows way down. The point cloud updates maybe once every 30 seconds. Is it just a problem of the amount of data being passed from the Kinect to rviz? Or could it be that my Asus EeeBox PC doesn't have enough umph to handle the data? Or is there some mysterious setting on rviz that only the enlightened know about which makes rviz more useful as a real-time observation tool for what your robot is up to?

I've run through the rviz documentation and aside from changing a few settings using the dynamic_reconfigure gui I can't find any solutions. Advice, anyone? Do any of you pro ROS users have optimal system setting suggestions?

Thanks,

Khiya

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
4

answered 2011-06-29 09:01:17 -0500

Mac gravatar image

updated 2011-06-29 09:07:40 -0500

The magic trick (particularly when dealing with Kinect point clouds) is to have serious hardware-accelerated 3D graphics. If you're doing 3D rendering in software, it will be agonizingly slow, no matter what.

Put a different way: a single Kinect pointcloud message is on the order of 10MB. Multiply that by 30fps, and you're putting serious, serious load on your system, even before you have to visualize it.

The PCL OpenNI wrappers and visualization tools might get you better results (although that's outside of ROS proper), but the sheer datarate problem isn't going away.

If you're willing to handle the clouds at a lower framerate (not that this will solve your visualization problem), take a look at Topic Tools, particularly the throttle node.

edit flag offensive delete link more

Comments

The EeeBox's graphic card is just an integrated intel processor. It's not going to be able to keep up with the number of points the kinect sends out.
tfoote gravatar imagetfoote ( 2011-06-29 10:25:44 -0500 )edit
1

answered 2011-06-29 09:40:26 -0500

fergs gravatar image

What graphics card does the Asus have? If you have a lower-end Intel integrated graphics card, you may not be able to do much. However, if you have ATI or nVidia card, try installing the restricted drivers.

edit flag offensive delete link more

Comments

I have an ATI Mobility Radeon X1400, can you tell me how to install the restricted drivers? I have the same slowness issue with the kinnect
ringo42 gravatar imageringo42 ( 2011-07-02 14:20:14 -0500 )edit
In your menu: System->Administration->Hardware Drivers
fergs gravatar imagefergs ( 2011-07-13 08:59:51 -0500 )edit
0

answered 2017-07-06 16:42:31 -0500

If your computer is in the limit for the representation you can decrease the frame rate of the rviz visualization. It will work better.

You can configure it in the rviz config file:

Global Options: Frame Rate: 10

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-06-29 08:04:30 -0500

Seen: 3,112 times

Last updated: Jul 06 '17