Ask Your Question
0

Swissranger camera - fail to open device through ethernet

asked 2011-06-23 07:59:57 -0500

diannay gravatar image

updated 2012-03-01 20:48:47 -0500

kwc gravatar image

Hi all,

I am running on the diamondback on a linux and am having problems when connecting the Swissranger (4k) using swissranger_camera found at http://www.ros.org/wiki/swissranger_c... . I have followed the respective tutorial and have noticed that the udev settings had to be changed for the "usb" method of transmission; is there an equivalent when using the ethernet?

Currently I get an error msg as such

usb_set_debug: Setting debugging level to 255 (on) usb_os_find_busses: Found 007 usb_os_find_busses: Found 006 usb_os_find_busses: Found 005 usb_os_find_busses: Found 004 usb_os_find_busses: Found 003 usb_os_find_busses: Found 002 usb_os_find_busses: Found 001 usb_os_find_devices: couldn't get connect info usb_os_find_devices: Found 001 on 007 error obtaining child information: Operation not permitted usb_os_find_devices: couldn't get connect info usb_os_find_devices: Found 001 on 006 error obtaining child information: Operation not permitted usb_os_find_devices: couldn't get connect info usb_os_find_devices: Found 001 on 005 error obtaining child information: Operation not permitted usb_os_find_devices: couldn't get connect info usb_os_find_devices: Found 001 on 004 error obtaining child information: Operation not permitted usb_os_find_devices: couldn't get connect info usb_os_find_devices: Found 001 on 003 error obtaining child information: Operation not permitted usb_os_find_devices: couldn't get connect info usb_os_find_devices: Found 002 on 002 skipping descriptor 0xFF skipping descriptor 0xB skipped 2 class/vendor specific endpoint descriptors skipped 7 class/vendor specific interface descriptors skipping descriptor 0x25 skipped 1 class/vendor specific endpoint descriptors skipped 19 class/vendor specific interface descriptors usb_os_find_devices: couldn't get connect info usb_os_find_devices: Found 001 on 002 error obtaining child information: Operation not permitted error obtaining child information: Operation not permitted usb_os_find_devices: couldn't get connect info usb_os_find_devices: Found 001 on 001 error obtaining child information: Operation not permitted usb_set_debug: Setting debugging level to 0 (off) What steps should I take to config this to use ethernet?

Thanks in advance!

edit retag flag offensive close merge delete

Comments

You probably won't need udev rules for ethernet.
dornhege gravatar image dornhege  ( 2011-06-24 01:35:57 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-06-23 23:28:28 -0500

Hi,

I run the camera as roslaunch sr_eth.launch. Before launching the swissranger_camera node, you should set the ethernet address of the camera by editing this launch file (ether_addr parameter) and any other parameter which best fits your application.

Cheers

edit flag offensive delete link more

Comments

thanks.For those who might be struggling, I had to do something like this: telnet default ethernet address 192.168.1.42, set the static address by fw_setenv staticip 192.168.1.33 and change my ipv4 settings to have the same three fields as the new static addr, mask 255,255,255,0; power off/on s4k
diannay gravatar image diannay  ( 2011-07-21 09:43:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-06-23 07:59:57 -0500

Seen: 331 times

Last updated: Jun 23 '11