remap not work in a ros-pioneer3AT launch file [closed]

asked 2013-11-19 22:57:51 -0600

mpp gravatar image

Hi, I've follow this guide(https ://docs.google.com/document/d/1C_GdAAQck-IT4H5GnsH3j6OezUbehUphtlnn8XU4XBk/edit#heading=h.5hhub0txkxyt) to configure my pioneer3AT with ROS Hydro. The code is here(https ://github.com/dawonn/ros-pioneer3at).

When launching the gmapping demo I have this roswtf output:

WARNING The following node subscriptions are unconnected:
 * /Pioneer3AT_rviz:
   * /Pioneer3AT_move_base/local_costmap/costmap_updates
   * /Pioneer3AT_move_base/NavfnROS/plan
   * /Pioneer3AT_move_base/global_costmap/costmap
   * /Pioneer3AT_move_base/global_costmap/costmap_updates
   * /tf_static
   * /Pioneer3AT/map_updates
   * /Pioneer3AT_move_base/local_costmap/costmap
   * /Pioneer3AT/particlecloud
   * /Pioneer3AT_move_base/local_costmap/footprint_layer/footprint_stamped
 * /nodelet_manager:
   * /Pioneer3AT/ps3joy/cmd_vel
 * /Pioneer3AT_gmapping:
   * /tf_static
   * /Pioneer3AT/laserscan
 * /Pioneer3AT_move_base:
   * /tf_static

I think that there are some <remap> problems, in particular in the file gmapping.launch:

<launch>
    <node pkg="gmapping" type="slam_gmapping" name="Pioneer3AT_gmapping" output="screen">   
      <rosparam file="$(find pioneer3at)/config/gmapping/gmapping.yaml" command="load" />

      <remap from="scan"          to="/Pioneer3AT/laserscan"/>
      <remap from="map"           to="/Pioneer3AT/map"/>
      <remap from="map_metadata"  to="/Pioneer3AT/map_metadata"/>
    </node>
</launch>

It is expected that the topic scan is remapped to the topic /Pioneer3AT/laserscan. If I echo the first I get the Hokuyo data but if I echo the second I get nothing! Why?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-09-11 15:22:10.495129

Comments

sorry for the text links but I have not enough karma to publish them

mpp gravatar imagempp ( 2013-11-19 22:58:32 -0600 )edit