Ask Your Question
1

SICK laser driver fails to start after initialization and handshake?

asked 2011-06-05 08:03:35 -0600

Kristiyan Georgiev gravatar image

updated 2011-06-06 03:02:53 -0600

Dear all,

I am getting trying to connect SICK LMS200 to ROS, but get the following error after it finds the port, and the laser info.

kris@IanCurtis:~/ros/$ rosrun sicktoolbox_wrapper sicklms

    *** Attempting to initialize the Sick LMS...
    Attempting to open device @ /dev/ttyUSB1
        Device opened!
    Attempting to start buffer monitor...
        Buffer monitor started!
    Attempting to set requested baud rate...
A Timeout Occurred!  2 tries remaining
A Timeout Occurred!  1 tries remaining
A Timeout Occurred - SickLIDAR::_sendMessageAndGetReply: Attempted max number of tries w/o success!
    Failed to set requested baud rate...
    Attempting to detect LMS baud rate...
        Checking 19200bps...
A Timeout Occurred!  2 tries remaining
A Timeout Occurred!  1 tries remaining
A Timeout Occurred - SickLIDAR::_sendMessageAndGetReply: Attempted max number of tries w/o success!
        Checking 38400bps...
        Detected LMS baud @ 38400bps!
        Operating @ 38400bps
    Attempting to sync driver...
        Driver synchronized!
    *** Init. complete: Sick LMS is online and ready!
    Sick Type: Sick LMS 200-30106
    Scan Angle: 180 (deg)
    Scan Resolution: 0.5 (deg)
    Measuring Mode: 8m/80m; 3 reflector bits
    Measuring Units: Centimeters (cm)

[ INFO] [1307303753.596993806]: Setting variant to (180, 0.500000)
    Requesting partial scan data stream...
        Data stream started!
[ERROR] [1307303753.973765819]: woah! error!
terminate called after throwing an instance of 'SickToolbox::SickThreadException'
Aborted
edit retag flag offensive close merge delete

Comments

Do you know if the scanner if working hardware-wise. Have you run another driver that works?
dornhege gravatar imagedornhege ( 2011-06-06 03:24:44 -0600 )edit
Yes, I have it working with a custom Java drivers @ 500K in 180 deg, with 1 deg resolution
Kristiyan Georgiev gravatar imageKristiyan Georgiev ( 2011-06-06 03:27:51 -0600 )edit
It seems odd, that the driver says it found the sick at 38.4k. I don't know this driver, but maybe you have to configure the serial port manually by `setserial /dev/ttyUSB0 baud_base 500000 uart 16654`. I don't know if that works for USB or helps at all.
dornhege gravatar imagedornhege ( 2011-06-06 23:49:24 -0600 )edit

Did you figure it out? I'm getting the same error.

xylo gravatar imagexylo ( 2012-06-08 12:14:05 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2011-09-02 11:51:52 -0600

kwc gravatar image

no activity > 1 month, closing

edit flag offensive delete link more
0

answered 2011-06-05 18:46:17 -0600

Eric Perko gravatar image

I don't think the sicktoolbox support the LMS100. See this mailing list thread about an LMS100 driver: http://code.ros.org/lurker/message/20100817.115932.63e6c490.en.html .

edit flag offensive delete link more

Comments

I am sorry there was a typo, the correct device is SICK LMS200, I am running Ubuntu 10.10
Kristiyan Georgiev gravatar imageKristiyan Georgiev ( 2011-06-06 03:02:15 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-06-05 08:03:35 -0600

Seen: 1,280 times

Last updated: Sep 02 '11