Ask Your Question
0

ar_pose on ROS Hydro

asked 2013-11-14 04:29:39 -0500

Mendelson gravatar image

Hi everyone!

I've been using ar_pose on ROS Fuerte for some time, but I want to update and start working with ROS Hydro. However, ar_pose doesn't work when using Groovy and Hydro.

Is there any update or any changes that should be made in order to have it working?

Thanks!

edit retag flag offensive close merge delete

Comments

1

This might be obvious, but make sure you're using the proper repo (https://github.com/IHeartEngineering/ar_tools). It's been moved around a bit lately.

Martin Günther gravatar imageMartin Günther ( 2013-11-14 21:57:55 -0500 )edit

Thank you for your comment! Well, I'm using this repo.

Mendelson gravatar imageMendelson ( 2014-01-20 01:32:01 -0500 )edit

1 Answer

Sort by » oldest newest most voted
3

answered 2013-11-14 17:11:24 -0500

Artem gravatar image

updated 2013-11-14 17:12:40 -0500

There were some compilation errors, after solving them, it works fine. It's a rosbuild package, so you have to create a rosbuild workspace then download ar_pose and build it.

edit flag offensive delete link more

Comments

Hi Artem. Thank you for this sugestion! It still doesn't work. Here is what I do: $roscore; $rosrun camera1394 camera1394_node _video_mode:=640x480_rgb8 /camera/image_raw:=usb_cam/image_raw; $ROS_NAMESPACE=usb_cam rosrun image_proc image_proc; $rosrun ar_pose ar_multi; $rosrun rviz rviz

Mendelson gravatar imageMendelson ( 2014-01-20 01:36:53 -0500 )edit

Also, I add "Camera", "Grid" and "Marker" on ''rviz'' and I set Fixed Frame to "/camera", Marker Topic to "visualization_marker", and Image Topic to "/usb_cam/image_raw". Any suggestion?

Mendelson gravatar imageMendelson ( 2014-01-20 01:39:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-11-14 04:29:39 -0500

Seen: 468 times

Last updated: Nov 14 '13