Ask Your Question
0

sound_play.h not in included in ros-hydro-sound-play?

asked 2013-11-13 11:42:28 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Currently, I am migrating my ros package from fuerte(rosbuild) to hydro(catkin). Even though the ros sound_play package is installed and runs properly, it seems the sound_play.h file is not included in the package anymore.

I worked around this problem by moving the file manually, but...

Can someone tell me whether this is intended and, if yes, the reason about this? The class SoundClient provided through this header file seems to be a very convenient tool to work with the sound_play node.

Thank you in advance! Adrian

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-11-13 11:53:48 -0600

Dirk Thomas gravatar image

That is a bug in the sound_play package. I have created a ticket here: https://github.com/ros-drivers/audio_common/issues/27

edit flag offensive delete link more

Comments

Thanks for your answer and the opened ticket!

EddiEdward gravatar imageEddiEdward ( 2013-11-13 11:57:39 -0600 )edit
0

answered 2014-02-18 03:29:49 -0600

davevh gravatar image

updated 2014-02-18 03:30:25 -0600

This appears to be a problem for Groovy too.

edit flag offensive delete link more

Comments

audio_common is released as a dry package on Groovy; it shouldn't have this problem. Can you ask this as a new question and provide a specific example where it isn't working?

ahendrix gravatar imageahendrix ( 2014-02-18 10:41:01 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-11-13 11:42:28 -0600

Seen: 375 times

Last updated: Feb 18 '14