ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Revision history [back]

You set "pub_map_odom_transform" to "true" for the argument provided in the launch file, but then set it to "false" when you set the actual corresponding parameter. That doesn´t make sense, better revert the lower line to

<param name="pub_map_odom_transform" value="$(arg pub_map_odom_transform)"/>

Also, you have set "/use_sim_time" to "true". If you are not playing back logfiles or work in simulation, this should be "false" (or not be set at all in the first place).

"base_stabilized" does not have to be part of your URDF model and from looking over things, after the two fixes above, things should work.