Ask Your Question

Revision history [back]

I just ran into the same problem (no idea why this didn't happen before). Turns out that eclipse can't parse localized gcc messages, so the auto-discovery of standard include paths from the gcc output fails. Solution:

LC_ALL=C eclipse

(Who actually wants localized error messages from gcc? The German translation usually makes them even more cryptic, IMO...)

I just ran into the same problem (no idea why this didn't happen before). Turns out that eclipse can't parse localized gcc messages, so the auto-discovery of standard include paths from the gcc output fails. Solution:

LC_ALL=C eclipse

Or, if you like that better: "Window -> Preferences -> C/C++ -> Build -> Environment", add two new environment variables "LANG" and "LC_ALL" and set them both to "en_US" or "C". Also see this eclipse forum post.

(Who actually wants localized error messages from gcc? The German translation usually makes them even more cryptic, IMO...)

I just ran into the same problem (no idea why this didn't happen before). Turns out that eclipse can't parse localized gcc messages, so the auto-discovery of standard include paths from the gcc output fails. Solution:

Solution:

    LC_ALL=C eclipse

Or, if you like that better: "Window -> Preferences -> C/C++ -> Build -> Environment", add two new environment variables "LANG" and "LC_ALL" and set them both to "en_US" or "C". Also see this [this eclipse forum post.

post](http://www.eclipse.org/forums/index.php/t/275956/). (Who actually wants wants localized error messages from gcc? The German translation usually makes them even more cryptic, IMO...)IMO...)

Update: After trying to reproduce this on a fresh work space, it turned out that I was wrong, LC_ALL has nothing to do with it. @stomic's answer is correct. I had to follow these steps (Eclipse Juno, ROS Groovy):

  1. right-click Project -> C/C++ General -> Code Analysis -> Preprocessor Includes -> Providers -> "Enable language settings providers for this project", then enable only "CDT GCC Built-in Compiler Settings"
  2. remove project (but keep contents on disk), then import project again
  3. you may have to right-click Project -> Index -> Rebuild