Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

With catkin_make all of the packages in a workspace are built with a single cmake and make invocation. The --pkg option will run make on the package specified, but it must run cmake on all of the packages, that is why you are getting the same error even with the --pkg option. If you don't want particular packages (packages with known problems) to be processed then you can delete them from the workspace or add a CATKIN_IGNORE file in the package's directory.

If you want a little more control over which packages get built when, then you can also try catkin_make_isolated which is capable of running cmake and make for only one package at a time.