Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Which PCL version you are tring for ? Last friday June 21, fuerte was updated and issues related to pre PCL 1.6 versions were resolved. Hence, this should work fine.

You can install the ros-fuerte-perception-pcl-fuerte-unstable (sudo apt-get install ros-fuerte-perception-pcl-fuerte-unstable) package which adds pcl16 and pcl16_ros packages that track PCL 1.6.

The namespaces, filenames, and everything else have been changed from pcl to pcl16, so you need to make some minor changes to your code. Like pcl::PointCloud<pcl::pointxyzrgb> becomes pcl16::PointCloud<pcl16::pointxyzrgb>. Doing it this way lets the two PCL versions coexist nicely.

Which PCL version you are tring trying for ? Last friday June 21, fuerte was updated and issues related to pre PCL 1.6 versions were resolved. Hence, this should work fine.

You can install the ros-fuerte-perception-pcl-fuerte-unstable (sudo apt-get install ros-fuerte-perception-pcl-fuerte-unstable) package which adds pcl16 and pcl16_ros packages that track PCL 1.6.

The namespaces, filenames, and everything else have been changed from pcl to pcl16, so you need to make some minor changes to your code. Like pcl::PointCloud<pcl::pointxyzrgb> becomes pcl16::PointCloud<pcl16::pointxyzrgb>. Doing it this way lets the two PCL versions coexist nicely.