Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

So I managed to solve this problem and was able to successfully build rviz. It turns out that I had two versions of Qt installed on my system by mistake, one older version installed using the standalone installer located under /Library/Frameworks, and the most current version installed using homebrew under /usr/local/lib. The installed version of shiboken and PySide was linked against the homebrew Qt installation.

Unfortunately the rviz configuration chose the old Qt installation under /Library/Frameworks and was passing this information on to shiboken as indicated by:

--include-paths=/Users/brian/ros_catkin_ws/src/rviz/src::/usr/include:/Library/Frameworks/QtCore.framework

The resulting warnings and errors messages like

enum 'QDateTimeEdit::Section' is specified in typesystem, but not declared

indicated that the PySide / shiboken version did not match up with the provided Qt Library headers.

Deleting all traces of the old Qt installation /Library/Frameworks fixed the problem for me.