Ask Your Question

Revision history [back]

All you have to do is to keep the robot_configuration.launch as it is and make sure that AMCL, map_server are not run and to set the static_map parameter to true in global_costmap_params.yaml

This is my global_costmap_params.yaml

global_costmap: global_frame: /map robot_base_frame: /base_link update_frequency: 10.0 publish_frequency: 10.0 static_map: true rolling_window: false

All you have to do is to keep the robot_configuration.launch as it is and make sure that AMCL, map_server are not run and to set the static_map parameter to true in global_costmap_params.yaml

This is my global_costmap_params.yaml

global_costmap:
  global_frame: /map
  robot_base_frame: /base_link
  update_frequency: 10.0
  publish_frequency: 10.0
  static_map: true
  rolling_window: false

false