Ask Your Question

Revision history [back]

I realized I had previously played with the #include in some of the files. I restored it to the default settings. Now I am receiving a different error:

opt/ros/fuerte/include/g2o/core/hyper_graph.h:59:22: error: redefinition of ‘class g2o::HyperGraph’ /home/samme/trunk/g2o/include/g2o/core/hyper_graph.h:46:9: error: previous definition of ‘class g2o::HyperGraph’

It seems that there is a conflict between the g2o that I installed and the one in ros-fuerte. Does anyone know how to uninstall the g2o that is already included in ROS?

Thanks,

Khalid