Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

I spent some time putting print statements here and there in the rospack.py and it turned out that it is simply a matter of setting up the environment variables correctly. Just set the following variables explicitly:

export ROS_ETC_DIR=/opt/ros/groovy/etc/ros
export ROS_ROOT=/opt/ros/groovy/share

I spent some time putting print statements here and there in the rospack.py and it turned out that it is simply a matter of setting up the environment variables correctly. Just set the following variables explicitly:

export ROS_ETC_DIR=/opt/ros/groovy/etc/ros
export ROS_ROOT=/opt/ros/groovy/share

Edit: The build needs the ROS_ROOT to be in /opt/ros/groovy/share/ros, so I ended up putting symbolic links in /opt/ros/groovy/share

After further investigation I spent some time putting print statements here and there in the rospack.py and it turned found out that it is simply a matter of setting up the environment variables correctly. Just set the following variables explicitly:exports should be put in .bashrc after calling the source.sh in your workspace:

export ROS_PACKAGE_PATH=$ROS_PACKAGE_PATH:/opt/ros/groovy/share:/opt/ros/groovy/stacks
export ROS_ETC_DIR=/opt/ros/groovy/etc/ros
export ROS_ROOT=/opt/ros/groovy/share

Edit: The build needs the ROS_ROOT to be in /opt/ros/groovy/share/ros, so I ended up putting symbolic links in /opt/ros/groovy/share