Ask Your Question

Revision history [back]

Try to install libsqlite3-dev package.

sudo apt-get install libsqlite3-dev

Assuming you're on Ubuntu/Debian.

Try to install libsqlite3-dev package.

sudo apt-get install libsqlite3-dev

Assuming you're on Ubuntu/Debian.


Once dev package installed, edit your CMakeLists.txt and add lines:

 # enable pkg_check_modules macro
 include(FindPkgConfig)
 pkg_check_modules(SQLITE sqlite3)

and then add the found library to your project by:

 target_link_libraries(${PROJECT_NAME} ${SQLITE__LIBRARIES})

or

 rosbuild_add_link_flags(${PROJECT_NAME} ${SQLITE_LDFLAGS})