Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Thanks for replying early,

I have set the fixed frame name in octomap_server launch file to /map, because it is the fixed frame used in rgbdslam (I could see it in the settings using the gui).

And I also changed the "send_cloud_rate" parameter in rgbdslam.launch to 3 (as in the example) but it didn't work either (1 node written only, as earlier). So I even tried to lower it to 1, but same thing. My cpu is a core i7 930, I have 6Gb ram, and no other cpu or ram consuming processes. I guess it's ok ?

Furthermore I saw that there are two different launch files for the octomap_server: one is present in the experimental branch launch directory and is named octomap_mapping.launch, and the other is the one that you quoted "rgbdslam/launch/octomap_server.launch". I saw that there are two additional parameters in that one:

<param name="filter_ground" value="false" /><!-- who knows where the floor is? -->
<param name="base_frame_id" value="/camera_rgb_optical_frame" /> <!--needs to be set, even if not used-->

I tried to roslaunch the octomap_server using this launch file (I copied it in the launch directory of the experimental branch), and checked that the fixed frame as well as the cloud_in parameters were set correctly ("/map" and "/rgbdslam/batch_clouds").

I am launching rgbdslam first, capture a scene (then stop with space), then I launch the octomap_server, and send the model and map using the gui (I can see the sending speed being more slow when changing the send cloud rate parameter).

But no success either (1 node only written to the .bt map file using "rosrun octomap_server octomap_saver mymap.bt")

So it seems that I did set the parameters correctly this time (frame names, and send rate) but it still doesn't work.

Any other advice would be much appreciated. I must also say that I am working under ubuntu 12.04 with fuerte, so in the same time I am doing a separate install of ubuntu 11.10 with ros electric, because they are the ones used in the wiki.

Hopping it will work better with those. Thanks again for your answer.