Ask Your Question

Revision history [back]

Are you sure you have set up everything correctly for using simulation time (so the timestamps from the bagfile are used)? Also see the Clock documentation regarding this. You have start a roscore, set the parameter:

rosparam set use_sim_time true

then start anything else you need and then play your bagfile with the --clock option:

rosbag play [your_bagfile] --clock

As for the rosconsole logger question, you can use the rxconsole tool to set different log levels for different nodes and get more debug output.