Ask Your Question

Revision history [back]

If you are sure that the odom and the scan topic are published correctly and gmapping connects to them (verify with rosnode info gmapping), this probably happens because of bad time stamps.

gmapping requires to have correct time stamps in the odometry message and the laser scan as well as in the tf transforms between the robot's base frame and your laser. If you are using several machines, make sure that their clocks are synchronized.

For more information on what exactly is the problem, start up rxconsole and enable debug for ros.gmapping.message_notifier as the warning message states.