Ask Your Question

Revision history [back]

I just was able to solve this myself.

For future readers:

This behaviour isn't caused by the costmaps themselves, but by the global_planner of the navigation stack. To fix this you'll need to set its parameter outline_map to false which is by default set to true. This isn't included in the parameter @ http://wiki.ros.org/global_planner#Parameters and i am unsure if you can set it directly from the launch file.

I changed the default value in the planner_core.cpp file located at navigation/global_planner/src/planner_core.cpp at line 149, which definitely isn't the cleanest way possible.

If you configured this you'll be able to use a rolling window for global maps aswell.

This Parameter has been added by the following PR see the following commit for details:

https://github.com/ros-planning/navigation/commit/57c3cb2357201e956be80324bb9b9282ff0fa051

I just was able to solve this myself.

For future readers:

This behaviour isn't caused by the costmaps themselves, but by the global_planner of the navigation stack. To fix this you'll need to set its parameter outline_map to false which is by default set to true. This isn't included in the parameter @ http://wiki.ros.org/global_planner#Parameters and i am unsure if you can set it directly from the launch file.

I changed the default value in the planner_core.cpp file located at navigation/global_planner/src/planner_core.cpp at line 149, which definitely isn't the cleanest way possible.

If you configured this you'll be able to use a rolling window for global maps aswell.

This Parameter has been added by the following PR see the following commit for details:

https://github.com/ros-planning/navigation/commit/57c3cb2357201e956be80324bb9b9282ff0fa051

EDIT:

If someone can change it in the ros wiki please do

I just was able to solve this myself.

For future readers:

This behaviour isn't caused by the costmaps themselves, but by the global_planner of the navigation stack. To fix this you'll need to set its parameter outline_map to false which is by default set to true. This isn't included in the parameter @ http://wiki.ros.org/global_planner#Parameters and i am unsure if you can set it directly from the launch file.

I changed the default value in the planner_core.cpp file located at navigation/global_planner/src/planner_core.cpp at line 149, which definitely isn't the cleanest way possible.

If you configured this you'll be able to use a rolling window for global maps aswell.

This Parameter has been added by the following PR see the following commit for details:

https://github.com/ros-planning/navigation/commit/57c3cb2357201e956be80324bb9b9282ff0fa051

EDIT:

If someone can change it in the ros wiki please do

EDIT:

i just added i to the wiki. Unfortunately i can't accept this answer myself