Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version
manipulator_ws/src/version1_desc/moveit_config/launch

I remember reading that creating a package inside a package usually brings up issues, so this part of the creation process confused me.

yes, this is your problem most likely.

Move the entire moveit_config directory (including all its contents) to manipulator_ws/src. Then delete the build, devel and install folders from your manipulator_ws (the last one only if it exists) and build your workspace again.

Now try again.

As to whether the MSA is "not as straight forward as they say?": in the end, it's the user which determiens where the output of the MSA should be stored. If you direct it to generate the package inside another package, that's where the output will be generated.

I'm not entirely sure I understand why you did that, but that's not too important either.

manipulator_ws/src/version1_desc/moveit_config/launch

I remember reading that creating a package inside a package usually brings up issues, so this part of the creation process confused me.

yes, this is your problem most likely.

Move the entire moveit_config directory (including all its contents) to manipulator_ws/src. Then delete the build, devel and install folders from your manipulator_ws (the last one only if it exists) and build your workspace again.again. Make sure to source devel/setup.bash after a successful build.

Now try again.

As to whether the MSA is "not as straight forward as they say?": in the end, it's the user which determiens where the output of the MSA should be stored. If you direct it to generate the package inside another package, that's where the output will be generated.

I'm not entirely sure I understand why you did that, but that's not too important either.

manipulator_ws/src/version1_desc/moveit_config/launch

I remember reading that creating a package inside a package usually brings up issues, so this part of the creation process confused me.

yes, this is your problem most likely.

Move the entire moveit_config directory (including all its contents) to manipulator_ws/src. Then delete the build, devel and install folders from your manipulator_ws (the last one only if it exists) and build your workspace again. Make sure to source devel/setup.bash after a successful build.

Now try again.

As to whether the MSA is "not as straight forward as they say?": in the end, it's the user which determiens determines where the output of the MSA should be stored. If you direct it to generate the package inside another package, that's where the output will be generated.

I'm not entirely sure I understand why you did that, but that's not too important either.