Ask Your Question

Revision history [back]

Hi from newbie ROS from Thailand. "Everything was working fine until i wanted to start scanning

$ roslaunch ydlidar lidar_view.launch" I change this line to run X2L Parameter roslaunch ydlidar_ros X2L.launch

that's found result :

process[ydlidar_node-1]: started with pid [10298] __ ______ _ ___ ____ _ ____
\ \ / / _ \| | |_ _| _ \ / \ | _ \ \ V /| | | | | | || | | |/ _ \ | |_) | | | | |_| | |___ | || |_| / ___ \| _ <
|_| |____/|_____|___|____/_/ __| _\

process[base_link_to_laser4-2]: started with pid [10299] [YDLIDAR INFO] Current Sampling Rate : 4K [YDLIDAR INFO] Now YDLIDAR is scanning ...... ^C[base_link_to_laser4-2] killing on exit [ydlidar_node-1] killing on exit 547438477696 thread has been canceled [YDLIDAR INFO] Now YDLIDAR Scanning has stopped ...... shutting down processing monitor... ... shutting down processing monitor complete done

but if i run : $ roslaunch ydlidar_ros lidar_view.launch program run completely but not shown data from lidar!

:ROS_MASTER_URI=http://localhost:11311

process[ydlidar_node-1]: started with pid [10803] process[base_link_to_laser4-2]: started with pid [10804] __ ______ _ ___ ____ _ ____
\ \ / / _ \| | |_ _| _ \ / \ | _ \ \ V /| | | | | | || | | |/ _ \ | |_) | | | | |_| | |___ | || |_| / ___ \| _ <
|_| |____/|_____|___|____/_/ __| _\

process[rviz-3]: started with pid [10814] Finally I can solve the problem ....

this git from https://github.com/YDLIDAR/ydlidar_ros/tree/master/launch

launch file lidar_view.launch is support G2A when you copy parameter in X2L.launch and paste in lunch.lunch and run lunch_view.lunch it'WORK!!!!! EUREKA!!!!!

for more parameter info please read: https://github.com/YDLIDAR/ydlidar_ros/blob/master/docs/paramters.md