Ask Your Question

Revision history [back]

You need to make sure you've compiled both pieces of software with the same version of the mav_planning_msgs package.

Something has changed in that message between versions so they don't line up. More than just that, it looks like you're using the wrong message type.

mav_planning_msgs/PolynomialTrajectory != mav_planning_msgs/PolynomialTrajectory4D

You need to make sure you've compiled both pieces of software with the same version of the mav_planning_msgs package.

Something has changed in that message between versions so they don't line up. More than just that, it looks like you're using the wrong message type.

mav_planning_msgs/PolynomialTrajectory != mav_planning_msgs/PolynomialTrajectory4D

You've subscribed to a topic with a specified type that is not the type the topic is publishing.